hdu5573 Binary Tree 二进制

Binary Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 952    Accepted Submission(s): 558
Special Judge


Problem Description
The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1. Say froot=1.

And for each node u, labels as fu, the left child is fu×2 and right child is fu×2+1. The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly Nsoul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x, the number at the node is fx (remember froot=1), he can choose to increase his number of soul gem by fx, or decrease it by fx.

He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N, then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given NK, help the King find a way to collect exactly N soul gems by visiting exactly K nodes.
 

Input
First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers N and K, which indicates soul gems the frog king want to collect and number of nodes he can visit.

 1T100.

 1N109.

 N2K260.
 

Output
For every test case, you should output "Case #x:" first, where x indicates the case number and counts from 1.

Then K lines follows, each line is formated as 'a b', where a is node label of the node the frog visited, and b is either '+' or '-' which means he increases / decreases his number by a.

It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

 

Sample Input
2 5 3 10 4
 

Sample Output
Case #1: 1 + 3 - 7 + Case #2: 1 + 3 + 6 - 12 +


思路参考:http://blog.csdn.net/u013068502/article/details/50094561


有两个地方想了一会才想明白,一个是d为什么要除以2,因为a + b + c要变成a - b - c那么也就是

a + b + c - 2(b + c),所以要变号的话肯定是(a + b + c - (a - b - c)) / 2 = b + c,然后再把b和c提取出来变号就可以了


还有一个地方是最后加减1的问题,为什么d必须是偶数,因为最小变换是1变号到-1,1 - (-1) = 2,也就是说最小

变换相差还是偶数呢,如果d = 100111(二进制),你尾巴上的那个1怎么办a - (-a) = 1,2a = 1,a = 1/2,肯定不行的

所以d必须得是偶数,例如d = 10(二进制),a - (-a) = 2a = 2,a = 1,只需要把1变号成-1就可以了,是可以满足的


#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <map>

using namespace std;

typedef long long ll;

int T, n, k, kase;
ll sum, d, x, t;
bool flag;
map<ll, int> mp;

int main()
{
	cin >> T;
	kase = 0;
	while (T--) {
		scanf("%d%d", &n, &k);
		sum = 0;
		for (int i = 0; i < k; i++) {
			sum = sum + ((ll)1 << i);
		}
		flag = false;
		d = sum - n;
		d = (d % 2 ? flag = true, d + 1 : d);
		x = d >> 1;
		mp.clear();
		for (int i = 0; i < 61; i++) {
			t = ((ll)1 << i) & x;
			if (t) {
				mp[t] = 1;
			}
		}
		printf("Case #%d:\n", ++kase);
		for (int i = 0; i < k; i++) {
			t = ((ll)1 << i);
			if (flag && i == k - 1) {
				t++;
			}
			printf("%lld ", t);
			if (mp[t] == 1) {
				printf("-");
			}
			else {
				printf("+");
			}
			puts("");
		}
	}
	return 0;
}


发布了198 篇原创文章 · 获赞 8 · 访问量 14万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章