Tempter of the Bone(DFS+剪枝)

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 87885    Accepted Submission(s): 23909


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
NO YES
 這一題爲什麼不能用bfs寫呢?因爲bfs是求最短時間!這裏是讓你求恰好是否在t秒到出口,你可以在訪問一個點之後再次訪問一個點

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<cmath>
const int N=10;
using namespace std;
char map1[N][N];
int vis[N][N];
int to[4][2]={1,0,-1,0,0,1,0,-1};
int n,m,ex,ey,t,escape;
void dfs(int sx,int sy,int cnt)
{
    int i,temp;
    if(sx==ex&&sy==ey&&cnt==t)
    {
        escape=1;
        return;
    }
    if(sx<=0||sx>n||sy<=0||sy>m)
    {
        return ;
    }
    /*
    奇偶剪枝:根據題目,doggie必須在第t秒到達門口。
    也就是需要走t-1步。設doggie開始的位置爲(sx,sy),
    目標位置爲(ex,ey).如果abs(ex-x)+abs(ey-y)爲偶數,
    則abs(ex-x)和abs(ey-y)奇偶性相同,所以需要走偶數步;
    當abs(ex-x)+abs(ey-y)爲奇數時,
    則abs(ex-x)和abs(ey-y)奇偶性不同,
    到達目標位置就需要走奇數步。
    先判斷奇偶性再搜索可以節省很多時間,
    不然的話容易超時。t-sum爲到達目標位置還需要多少步。
    因爲題目要求doggie必須在第t秒到達門的位置,
    所以(t-cnt)和abs(ex-x)+abs(ey-y)的奇偶性必然相同。
    因此temp=(t-cnt)-abs(ex-x)+abs(ey-y)必然爲偶數。*/

    temp = (t-cnt) - abs(sx-ex) - abs(sy-ey);
    if(temp<0||temp&1)
    {
        return;
    }
    for(i=0;i<4;i++)
    {
        if(map1[sx+to[i][0]][sy+to[i][1]]!='X')
        {
            map1[sx+to[i][0]][sy+to[i][1]]='X';
            dfs(sx+to[i][0],sy+to[i][1],cnt+1);
            if(escape)
            {
                return;
            }
            map1[sx+to[i][0]][sy+to[i][1]]='.';
        }
    }
    return;
}
int main()
{
    int i,j,sx,sy,num_wall;
    while(cin>>n>>m>>t&&n+m+t)
    {
        escape=0;
        num_wall=0;
        memset(vis,0,sizeof(vis));
        memset(map1,0,sizeof(map1));
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                cin>>map1[i][j];
                if(map1[i][j]=='S')
                {
                    sx=i;
                    sy=j;
                }
                if(map1[i][j]=='X')
                {
                    num_wall++;
                }
                if(map1[i][j]=='D')
                {
                    ex=i;
                    ey=j;
                }
            }
        }
        if(n*m-num_wall<=t)
        {
            cout<<"NO"<<endl;
            continue;
        }
        map1[sx][sy]='X';
        dfs(sx,sy,0);
        if(escape)
        {
            cout<<"YES"<<endl;
        }
        else
        {
            cout<<"NO"<<endl;
        }
    }
}

發佈了4 篇原創文章 · 獲贊 22 · 訪問量 20萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章