Bomb(數位Dp)

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 10373    Accepted Submission(s): 3657


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
3 1 50 500
 

Sample Output
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

#include<cstdio>
#include<iostream>
#include<cstring>
#define ll long long
using namespace std;
ll dp[21][3];
void init()
{
    int i;
    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
    /*
    dp[i][0]代表長度爲 i 並且不含有49的數字的個數;
  dp[i][1]代表長度爲 i 並且不含有49,但是最高位是9的數字的個數;
  dp[i][2]代表長度爲 i 並且含有49的數字的個數。
    */
    for(i=1;i<21;i++)
    {
        dp[i][0]=dp[i-1][0]*10-dp[i-1][1];// 表示長度爲 i 的不含有49的數字的個數等於
       // 長度爲 i - 1 的不含有49的數字的個數*當前的數字
        dp[i][1]=dp[i-1][0];//表示長度爲 i 的並且不含有49同時最高位是9的數字的個數等於,
       //長度爲 i - 1 的不含有49的數字的個數,
       //因爲只要在它的高一位加上一個9就可以了。
        dp[i][2]=dp[i-1][2]*10+dp[i-1][1];
         /*
          表示長度爲 i 的含有49的數字的個數等於,
          長度爲 i - 1 的數字的個數*當前的數字
          ,再加上長度爲 i - 1 的
          並且不含有49同時最高位是9的數字的個數,因爲這個時候,
          只要在高一位加上一個4就可以了,
          這樣在最高的兩位就組成了一個49。*/
    }
}
int main()
{
    int i,t,len,last,flag,a[22];
    ll ans,n;
    init();
    cin>>t;
    while(t--)
    {
        memset(a,0,sizeof(a));
        last=flag=ans=0;//flag用於判斷這個數之前的數是否是49
        cin>>n;
        n++;
        len=1;
        while(n)
        {
            a[len++]=n%10;
            n/=10;
        }
        len--;
        for(i=len;i>=1;i--)
        {
            ans+=dp[i-1][2]*a[i];//在i之前的一位所有含有49數的種類*當前數
            if(flag)//如果這個數與前一個數組合成49
            {
                ans+=dp[i-1][0]*a[i];//這個數的種類就是下一位所有的非49數*當前數
                //比如4960,應該是6*1=6;
            }
            if(!flag&&a[i]>4)
            {
                ans+=dp[i-1][1];
            }
            if(last==4&&a[i]==9)
            {
                flag=true;
            }
            last=a[i];
        }
        printf("%I64d\n",ans);
    }
}
因爲後面的for循環求的是(0,n)的開區間的符合條件的數字的數目,題目要求[1,n]這個區間內的符合條件的數字的數目,所以要把區間的右端點加1。這樣的處理方式比較方便,就不用判斷這個端點是不是如何條件的數字了。
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章