杭州ACM 1087 Super Jumping! Jumping! Jumping!

大學時搞ACM,想想也要在這裏寫個關於ACM的分類,先佔佔位以後記的。省的忘記了,個人比較喜歡動態規劃,記的那時候這題用的也是動態規劃,寫的比較早,可以寫的不是太好,看的人別太在意。

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19460    Accepted Submission(s): 8406


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
4 10 3
 


code

#include<stdio.h>
struct CHESS{
    int max;
    int sum;
}chess[1111];
int main()
{
    int i,j,n,temp,maxsum;
    while(scanf("%d",&n),n!=0)
    {
          for(i=0;i<n;i++)
          {
            scanf("%d",&temp);
            if(i==0)
                maxsum=temp;
            chess[i].max=temp;
            chess[i].sum=temp;
            for(j=0;j<i;j++)
            {
                if(temp>chess[j].max)
                {
                    if((temp+chess[j].sum)>chess[i].sum)
                    {
                        chess[i].sum=temp+chess[j].sum;
                        chess[i].max=temp;
                    }
                }
            }
            if(chess[i].sum>maxsum)
                            maxsum=chess[i].sum;
          }
          printf("%d\n",maxsum);
    }
    return 0;
}



發佈了37 篇原創文章 · 獲贊 6 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章