hdu 5119 dP

E - Happy Matt Friends
Time Limit:6000MS     Memory Limit:510000KB     64bit IO Format:%I64d & %I64u

Description

Matt has N friends. They are playing a game together. 

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins. 

Matt wants to know the number of ways to win.
 

Input

The first line contains only one integer T , which indicates the number of test cases. 

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 10 6). 

In the second line, there are N integers ki (0 ≤ k i ≤ 10 6), indicating the i-th friend’s magic number.
 

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
 

Sample Input

2 3 2 1 2 3 3 3 1 2 3
 

Sample Output

Case #1: 4 Case #2: 2

Hint

In the first sample, Matt can win by selecting: friend with number 1 and friend with number 2. The xor sum is 3. friend with number 1 and friend with number 3. The xor sum is 2. friend with number 2. The xor sum is 2. friend with number 3. The xor sum is 3. Hence, the answer is 4. 
 

分析:首先看題發現並沒有什麼明顯的規律,然後考慮dp
      dp[i][j]表示 前i個數裏面異或值爲j的方法數
      找到遞推關係即可;
#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
using namespace std;
typedef long long ll;

const int maxn=1e6+100;
int n,m,test;
int a[maxn];
ll dp[44][maxn];

ll solve()
{
   memset(dp,0,sizeof(dp));
   dp[1][0]=dp[1][a[1]]=1;
   for(int i=2;i<=n;i++)
   {
      for(int j=0;j<maxn;j++)dp[i][j]+=dp[i-1][j];
      for(int j=0;j<maxn;j++)dp[i][a[i]^j]+=dp[i-1][j];
   }
   ll ans=0;
   for(int i=m;i<maxn;i++)
    ans+=dp[n][i];
   return ans;
}

int main()
{
   int T,test=1;
   scanf("%d",&T);
   while( T-- )
   {
       scanf("%d%d",&n,&m);
       for(int i=1;i<=n;i++)
         scanf("%d",&a[i]);

       ll ans=solve();
       printf("Case #%d: %lld\n",test++,ans);
   }
   return 0;
}

發佈了244 篇原創文章 · 獲贊 17 · 訪問量 17萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章