POJ1979 Red and Black

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 28659   Accepted: 15614

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source


簡單的DFS,練練手,直接代碼吧。


Source Code

Problem: 1979		User: lk951208
Memory: 252K		Time: 0MS
Language: C++		Result: Accepted
Source Code
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAXN 300
using namespace std;

char mp[MAXN][MAXN];
int N,M,ans;

void dfs(int r,int c)
{
    if(r<0 || r>=M || c<0 || c>=N) return;
    if(mp[r][c]=='#') return;
    if(mp[r][c]!='#') {ans++;mp[r][c]='#';}
    dfs(r+1,c);
    dfs(r-1,c);
    dfs(r,c+1);
    dfs(r,c-1);
}

int main()
{
    while(scanf("%d%d",&N,&M) && N && M)
    {
        int x,y;ans=0;
        memset(mp,0,sizeof(mp));
        for(int i=0;i<M;i++)
        {
            scanf("%s",mp[i]);
            for(int j=0;j<N;j++)
            if(mp[i][j]=='@') {x=i;y=j;}
        }
        dfs(x,y);
        printf("%d\n",ans);
    }
    return 0;
}

發佈了50 篇原創文章 · 獲贊 2 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章