POJ1258 Agri-Net

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 48633   Accepted: 20146

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

題目:這就是一道裸的Prim的題:

代碼如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define MAXN 500
using namespace std;

int n,sum;
int dis[MAXN][MAXN];
int cost[MAXN];
bool vis[MAXN];

void Prim(int start)
{
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
        cost[i]=dis[start][i];
    sum=0;
    vis[start]=true;
    for(int i=2;i<=n;i++)
    {
        int nm=0x3f3f3f,k;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && cost[j]<nm)
            {
                nm=cost[j];
                k=j;
            }
        }
        vis[k]=true;
        sum+=nm;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && cost[j]>dis[k][j])
            {
                cost[j]=dis[k][j];
            }
        }
    }
}

int main()
{
    memset(dis,0x3f3f3f,sizeof(dis));
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
                scanf("%d",&dis[i][j]);
        }
        Prim(1);
        printf("%d\n",sum);
    }
    return 0;
}

發佈了50 篇原創文章 · 獲贊 2 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章