poj 3186 Treats for the Cows(區間dp)

Treats for the Cows
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4375   Accepted: 2226

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. 

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally? 

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample: 

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2). 

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

題目要求從兩邊取,權值爲a[i]*cnt,這樣就很不好處理。

假設從裏面往外取,取最裏面的那個權值爲a[i]*n,倒數第二個爲a[j]*(n-1),

dp[i][j]表示取完[i,j]區間的最大值,那麼由dp[i][i]很容易得到dp[i][i+1];

dp[i][j]=max(dp[i+1][j]+a[i]*cnt,dp[i][j-1]+a[j]*cnt);  (cnt爲第幾次取數字)

最終答案就是dp[1][n];


#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
using namespace std;
#define ll long long
#define mem(a,t) memset(a,t,sizeof(a))
#define N 2005
const int M=100005;
const int inf=0x1f1f1f1f;
int a[N],dp[N][N];
int main()
{
    int i,j,k,n;
    while(~scanf("%d",&n))
    {
        mem(dp,0);
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);     //從裏向外逆推區間
            dp[i][i]=a[i]*n;    //最後取的是a[i]
        }
        for(k=1;k<n;k++) //區間長度爲k+1時
        {
            for(i=1;i+k<=n;i++)      //枚舉區間長度爲k+1的每個區間起點
            {
                j=i+k;               //該區間終點爲j=i+k
                dp[i][j]=max(dp[i+1][j]+a[i]*(n-k),dp[i][j-1]+a[j]*(n-k));
            }            //該區間的最優解爲先取左邊或者右邊兩者的最大值
        }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}



發佈了336 篇原創文章 · 獲贊 29 · 訪問量 29萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章