poj 2378 Tree Cutting (樹形dp)

Tree Cutting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3910   Accepted: 2347

Description

After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses. 

Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ. 

Please help Bessie determine all of the barns that would be suitable to disconnect.

Input

* Line 1: A single integer, N. The barns are numbered 1..N. 

* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

Output

* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".

Sample Input

10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8

Sample Output

3
8

Hint

INPUT DETAILS: 

The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles. 

OUTPUT DETAILS: 

If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).

Source

類似於poj3107

求刪除一個點後,形成的森林中,每棵樹中最大節點數不大於原樹節點數目的一半。

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
#define ll long long
#define N 11000
#define mem(a,t) memset(a,t,sizeof(a))
const int inf=1000005;
int cnt,n;
struct node
{
    int v,next;
}e[N*2];
int head[N];
int num[N];
int ans[N];
int n1;
void add(int u,int v)
{
    e[cnt].v=v;
    e[cnt].next=head[u];
    head[u]=cnt++;
}

void dfs(int u,int len,int fa)
{
    int i,v,sum=0,tmp=0;
    num[u]=1;
    for(i=head[u];i!=-1;i=e[i].next)
    {
        v=e[i].v;
        if(v!=fa)
        {
            dfs(v,len+1,u);
            tmp=max(tmp,num[v]);
            num[u]+=num[v];
        }
    }

    int t=max(tmp,n-num[u]);
    if(t<=n/2)
        ans[n1++]=u;
}

int main()
{
    //freopen("in.txt","r",stdin);
    int i,u,v;
    while(~scanf("%d",&n))
    {
        cnt=0;
        mem(head,-1);
        for(i=1;i<n;i++)
        {
            scanf("%d%d",&u,&v);
            add(u,v);
            add(v,u);
        }
        mem(num,0);
        n1=0;
        dfs(1,0,-1);
        sort(ans,ans+n1);
        for(i=0;i<n1;i++)
            printf("%d\n",ans[i]);
    }
    return 0;
}








發佈了336 篇原創文章 · 獲贊 29 · 訪問量 29萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章