POJ 2996 Help Me with the Game 大模擬

Help Me with the Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2927   Accepted: 1900

Description

Your task is to read a picture of a chessboard position and print it in the chess notation.

Input

The input consists of an ASCII-art picture of a chessboard with chess pieces on positions described by the input. The pieces of the white player are shown in upper-case letters, while the black player's pieces are lower-case letters. The letters are one of "K" (King), "Q" (Queen), "R" (Rook), "B" (Bishop), "N" (Knight), or "P" (Pawn). The chessboard outline is made of plus ("+"), minus ("-"), and pipe ("|") characters. The black fields are filled with colons (":"), white fields with dots (".").

Output

The output consists of two lines. The first line consists of the string "White: ", followed by the description of positions of the pieces of the white player. The second line consists of the string "Black: ", followed by the description of positions of the pieces of the black player.

The description of the position of the pieces is a comma-separated list of terms describing the pieces of the appropriate player. The description of a piece consists of a single upper-case letter that denotes the type of the piece (except for pawns, for that this identifier is omitted). This letter is immediatelly followed by the position of the piece in the standard chess notation -- a lower-case letter between "a" and "h" that determines the column ("a" is the leftmost column in the input) and a single digit between 1 and 8 that determines the row (8 is the first row in the input).

The pieces in the description must appear in the following order: King("K"), Queens ("Q"), Rooks ("R"), Bishops ("B"), Knights ("N"), and pawns. Note that the numbers of pieces may differ from the initial position because of capturing the pieces and the promotions of pawns. In case two pieces of the same type appear in the input, the piece with the smaller row number must be described before the other one if the pieces are white, and the one with the larger row number must be described first if the pieces are black. If two pieces of the same type appear in the same row, the one with the smaller column letter must appear first.

Sample Input

+---+---+---+---+---+---+---+---+
|.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
+---+---+---+---+---+---+---+---+
|:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
+---+---+---+---+---+---+---+---+
|...|:::|.n.|:::|...|:::|...|:p:|
+---+---+---+---+---+---+---+---+
|:::|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|...|:::|...|:::|.P.|:::|...|:::|
+---+---+---+---+---+---+---+---+
|:P:|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
+---+---+---+---+---+---+---+---+
|:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
+---+---+---+---+---+---+---+---+

Sample Output

White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6

對於這道題,其實不算難,還是要灰常細心,當然還是各種坑爹貨,比如,數字是從下向上1到8的序列,並且此題建議用C風格的scanf控制輸入格式,這樣對於複雜讀入處理簡單,先打出簡單的表,然後按照KQRBNP的順序輸出,這道題還有一個坑點就是白棋是字母優先輸出,黑棋是數字優先輸出,解決方法就是用不同的白旗和黑棋分別用不同的函數查找,白旗由下向上查找,黑氣由上向下查找,查找到立刻輸出,這樣題目基本就AC了,需要細心的地方特別多,編的時候要注意。

下面是AC代碼:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
char chess[35][35],final[10][10];
char ch[40],ch1,ch2;
int flag;
void findw(char p)
{
	int i,j;
	for(j=8;j>0;j--)
		for(i=1;i<=8;i++)
		{
			if(final[j][i]==p)
			{
				if(flag==1)
					flag=0;
				else
					printf(",");
				if(p!='P')
					printf("%c",p);
				printf("%c%d",i-1+'a',9-j);
			}

		}
}
void findb(char p)
{
	int i,j;
	for(j=1;j<=8;j++)
		for(i=1;i<=8;i++)
		{
		if(final[j][i]==p)
		{
			if(flag==1)
				flag=0;
			else
				printf(",");
			if(p!='p')
				printf("%c",p-32);
			printf("%c%d",i-1+'a',9-j);
			}
		}
}
int main()
{
	int i,j,k;
	for(i=1;i<=8;i++)
	{
		scanf("%s",ch);
		scanf("%s",chess[i]);
	}
	scanf("%s",ch);
	for(i=1;i<=8;i++)
	{
		k=1;
		for(j=2;j<35;j+=4)
		{
			final[i][k]=chess[i][j];
			k++;
		}
	}
	flag=1;
	printf("White: ");
    findw('K');
    findw('Q');
    findw('R');
    findw('B');
    findw('N');
    findw('P');
	flag=1;
	printf("\nBlack: ");
	findb('k');
	findb('q');
	findb('r');
	findb('b');
	findb('n');
	findb('p');
	printf("\n");
	return 0;
}


發佈了43 篇原創文章 · 獲贊 4 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章