POJ.2182.Lost Cows 非遞歸線段樹 0ms

Lost Cows

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10681 Accepted: 6852

Description
N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood ‘watering hole’ and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he’s not very good at observing problems. Instead of writing down each cow’s brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input
* Line 1: A single integer, N

  • Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output
* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

Source
USACO 2003 U S Open Orange

// Source Code
// Problem: 2182        User: BlackKitty
// Memory: 320K     Time: 0MS
// Language: C++        Result: Accepted

#include <stdio.h>
#include <stdlib.h>
#define M 8001
int s[M] = { 1 }, t[M<<2];

void bd(int l, int r, int v){
//建樹
    t[1] = r;
    r <<= 2;
    for (int i = 2; i <= r; i++){
        t[i] = (t[i >> 1] >> 1) + ((t[i >> 1] & 1) && (~i & 1));
    }
}

int qy(int k, int l, int r, int v){
//查詢並刪除元素
    int m;
    for (;;){
        m = (l + r) >> 1;
        if (l == r)
            return r;
        if (k > t[v << 1]){
            t[v << 1 | 1]--;
            k -= t[v << 1];
            l = m + 1;
            v = v << 1 | 1;
        }
        else{
            t[v << 1]--;
            r = m;
            v = v << 1;
        }
    }
}


int main(){
    int i,j,n;
    scanf("%d", &n);
    bd(1, n, 1);
    for (i = 1; i < n;i++){
        scanf("%d", s + i); 
        s[i]++;
    }
    for (i = n - 1; i >= 0; i--)
        s[i] = qy(s[i], 1, n, 1);
    for (i = 0; i < n;printf("%d\n", s[i++]));

    return 0;
}
發佈了30 篇原創文章 · 獲贊 105 · 訪問量 42萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章