Number Sequence 重在找規律,48一循環


Number Sequence
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 27   Accepted Submission(s) : 0

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5
#include<stdio.h>
#include<string.h>
int main()
{
 int mod(int a,int b,int n);
 int A,B,n;
 while(scanf("%d%d%d",&A,&B,&n)!=EOF)
 {
  if(A==0&&B==0&&n==0)
  break;
  int c[100],k;
  A=A%7;
  B=B%7;
  n=n%48;
  k=mod(A,B,n);
  printf("%d\n",k);
 }
 return 0;
} 
int mod(int a,int b,int n)
{
 if(n==1)
 return 1;
 else 
    if(n==2)
    return 1;
    else
    return (a*mod(a,b,n-1)+b*mod(a,b,n-2))%7;
}
發佈了38 篇原創文章 · 獲贊 7 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章