Period||POJ1961

link:http://poj.org/problem?id=1961
Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

題解:這個和poj2406基本相似
可以看看這個http://blog.csdn.net/csdn_muxin/article/details/77231807
kmp簡單運用

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
char s[1000100];
int next[1000100];
void kmp()
{
    int n=strlen(s);
    int i,j;
    i=0,j=-1;
    next[0]=-1;
    while(s[i])
    {
        if(j==-1||s[i]==s[j])
        {
            i++,j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
int main()
{
    int n,i,j,c=1;
    while(scanf("%d",&n),n!=0)
    {
        scanf("%s",s);
        kmp();
        printf("Test case #%d\n",c++);
        for(i=1;i<=n;i++)
        {
            if(i%(i-next[i])==0&&i/(i-next[i])>1)
            {
                printf("%d %d\n",i,i/(i-next[i]));
            }
        }
        printf("\n");
    }
return 0;
}
發佈了105 篇原創文章 · 獲贊 26 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章