杭電 ACM 1014

Uniform Generator


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10985    Accepted Submission(s): 4337




Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form


seed(x+1) = [seed(x) + STEP] % MOD


where '%' is the modulus operator. 


Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1. 


For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations. 


If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1. 


Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers. 
 


Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
 


Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
 


Sample Input
3 5
15 20
63923 99999
 


Sample Output
         3         5    Good Choice


        15        20    Bad Choice


     63923     99999    Good Choice
 


Source
South Central USA 1996
 


Recommend

JGShining

題很簡單,就是計算0 - mod-1 的和,然後與一個週期內的所有數的和相比,若相等就是Good Choice 否則 Bad Choice。有一點要注意的是輸出格式,Goode choice 或 Bad choice 是左對齊到25行,所以在上面兩個輸出之後要輸出四個空格。

代碼:

#include<stdio.h>
int random(int step, int mod, int x)
{
return (x + step)%mod;
}
int main(void)
{
int sum;
int step, mod;
int i, head, next, x;
while(scanf("%d %d", &step, &mod) != EOF)
{
if(mod == 0)
break;
sum = 0;
for(i = 0;i < mod;i++)
{
sum += i;
}
head = random(step, mod, 0);
sum -= head;
x = head;
while(head != (next = random(step, mod, x)))
{
x = next;
sum -= next;
}
/*
printf("%10d%10d    ",step,mod);
        if(!sum)
printf("Good Choice\n\n");
        else 
printf("Bad Choice\n\n");
*/
printf("%10d%10d", step, mod);
printf("    ");
if(sum)
printf("Bad Choice\n\n");
else
printf("Good Choice\n\n");

}
return 0;
}

發佈了39 篇原創文章 · 獲贊 6 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章