Wolf and Rabbit (hdu_1222) 欧几里德

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6954    Accepted Submission(s): 3463


Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input
2 1 2 2 2
 

Sample Output
NO YES
 
题目大意:。。。。

解题思路:欧几里德,如果m和n互素,则互走过所有洞;

代码如下:

#include"iostream"
#include"cstring"
#include"cstdio"
using namespace std;

int gcd(int a, int b){
    if(b == 0) return a;
    return gcd(b, a % b);
}

int main(){
    int T;
    scanf("%d", &T);
    while(T --){
        int n, m;
        scanf("%d%d",&n, &m);
        if(gcd(n, m) == 1) printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}


发布了95 篇原创文章 · 获赞 1 · 访问量 4万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章