poj2828(線段樹)


Buy Tickets
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 12459   Accepted: 6159

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The nextN lines contain the pairs of values Posi and Vali in the increasing order ofi (1 ≤ iN). For each i, the ranges and meanings ofPosi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind thePosi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the valueVali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243


數據從後面開始處理,保證前面剛好有pos個空格就行了,開始的時候全部都是空格,插入之後此位置就不是空格了,這樣一直模擬到最後就是最後隊列的順序!!


#include<set>
#include<queue>
#include<cmath>
#include<cstdio>
#include<vector>
#include<string>
#include<utility>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define Inf (1<<30)
#define LL long long
#define MOD 1000000009
#pragma comment(linker, "/STACK:102400000,102400000")  
using namespace std;
const int MM = 210005;
int a[MM];
int p[MM], v[MM];
int sum[MM << 2];
void pushup(int o)
{
	sum[o] = sum[2 * o] + sum[2 * o + 1];
}
void build(int o, int L, int R)
{
	if (L == R)sum[o] = 1;
	else
	{
		int mid = L + (R - L) / 2;
		build(2 * o, L, mid);
		build(2 * o + 1, mid + 1, R);
		pushup(o);
	}
}
void update(int o, int L, int R, int p, int v, int add)
{
	if (L == R)a[L] = v, sum[o] = 0;
	else
	{
		int mid = L + (R - L) / 2;
		if (sum[2 * o] + add > p)update(2 * o, L, mid, p, v, add);
		else update(2 * o + 1, mid + 1, R, p, v, add + sum[2 * o]);
		pushup(o);
	}
}
int main() {
	int n, m, q;
	//freopen("D:\\oo.txt","r",stdin);
	while (~scanf("%d", &n))
	{
		build(1, 1, n);
		for (int i = 0; i < n; i++)scanf("%d%d", &p[i], &v[i]);
		for (int i = n - 1; i >= 0; i--)
			update(1, 1, n, p[i], v[i], 0);
		for (int i = 1; i <= n; i++)
		{
			if (i != 1)printf(" ");
			printf("%d", a[i]);
		}
		puts("");
	}
	return 0;
}


發佈了123 篇原創文章 · 獲贊 14 · 訪問量 14萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章