HDU-1008-Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 74013    Accepted Submission(s): 40781



Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case. 
 

Sample Input
1 2 3 2 3 1 0
 

Sample Output
17 41
 

Author
ZHENG, Jianqiang
 

Source

上升爲6秒,下降爲4秒,暫停爲5秒,而且都是從第0層開始的。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int n,a[101];
	while(scanf("%d",&n)!=EOF&&n){
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
		}
		int sum=(a[0]-0)*6+5,m=a[0];
		if(n==1){
			sum=sum;
		}else{
			for(int i=1;i<n;i++){
			    if(a[i]>m){
				    sum+=(a[i]-m)*6+5;
				    m=a[i];
			    }
			    else if(a[i]<m){
				    sum+=(m-a[i])*4+5;
				    m=a[i];
			    }else{
				    sum+=5;
			    }
		    }	
		}
		printf("%d\n",sum);
	}
return 0;
}





發佈了60 篇原創文章 · 獲贊 1 · 訪問量 5607
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章