HDU-1019-Least Common Multiple

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54134    Accepted Submission(s): 20620



Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
 

Sample Output
105 10296
多個數的最大公倍數問題,兩個兩個的求解最大公倍數。
#include<cstdio>
#include<cstdlib>
int LIM(int a,int b)
{
	if(b==0){
		return a;
	}else{
		return LIM(b,a%b);
	}
}
int main()
{
	int T,n;
	long long int a[1000];
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		for(int i=0;i<n;i++){
			scanf("%lld",&a[i]);
		}
		long long int h=1;
		long long int m;
		for(int i=0;i<n;i++){
			m=LIM(h,a[i]);
			h=h*a[i]/m;
		}
		printf("%lld\n",h);
	}
return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章