POJ 2533 最長上升子序列 [動態規劃 + 二分搜索]

題幹

Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input

7
1 7 3 5 9 4 8
Sample Output

4

題解

#include<cstdio>
const int INF = 1e9;
const int MAX = 100010;
typedef int T;//root[]數組的數據類型
//二分搜索
int binary_search(T s[], const int digit, const int len){
  int l = 1, r = len, mid;
  //s[]數組大小爲 len - 1 ,且一定是上升序列(可反證法證明)
  while(l<r){
     mid = (l + r) / 2;
     if(s[mid] == digit){
        return mid;//如果s[k]==digit,則返回k
     }else if(s[mid] > digit){
        r = mid;
     }else{
        l = mid + 1;
     }
  }
  //返回 max{ k } + 1(k滿足 s[k] < digit)
  return l;
}
inline int LIS(T root[], int length){
  int len = 1, j;
  T s[MAX];//表示當dp[k]==i時,s[i]值爲min{root[k]}
  for(int i=1;i<=length;i++){
     s[len] = INF;//len一定指向s數組最後一個有效元素的下一個位置
     j = binary_search(s,root[i], len);
     if(j==len){//當j==len, root[i]爲最長子序列中元素,len++
       len ++;
     }
     s[j] = root[i];//保證當dp[k]==i時,s[i]值爲min{root[k]}
  }
  return len-1;
}
int main(){
  //freopen("in.txt","r",stdin);
  //freopen("out.txt","w",stdout);
  int N;
  T root[MAX];//原數組(字符串或者數列),root[0]不保存數據
  while(~scanf("%d",&N)){
     for(int i=1;i<=N;i++){
        scanf("%d",&root[i]);
     }
     printf("%d\n",LIS(root,N));
  }
  return 0;
}
發佈了40 篇原創文章 · 獲贊 0 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章