HDU 2476 String painter(區間DP)

原題地址

String painter

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3726 Accepted Submission(s): 1740


Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.

Output
A single line contains one integer representing the answer.

Sample Input
zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd

Sample Output
6 7

題意:
給你兩個字符串,讓你從字符串1刷成字符串2的樣子,每次你只能將一個區間內的字符刷成同一個字符。

思路:
區間DP。一開始將字符串初始爲空串,記dp[ i ][ j ]爲,將從 i ~ j 的字符串刷成目標串所用的最少步數。可以將dp[ i ][ j ]初始化爲dp[ i-1 ][ j ],然後比較新添加的一位如果和區間內的p位相同,則dp[i][j] = min(dp[i][j],(dp[i+1][p]+dp[p+1][j]))

AC代碼:
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>

using namespace std;

char str1[111],str2[111];
int dp[111][111];
int ans[111];
int main()
{
    while(~scanf("%s",&str1))
    {
        scanf("%s",&str2);
        int i,j,l;
        l=strlen(str1);
        memset(dp,0,sizeof(dp));
        for(j=0;j<l;j++)
        {
            for(i=j;i>=0;i--)
            {
                dp[i][j]=dp[i+1][j]+1;
                for(int p=i+1;p<=j;p++)
                {
                    if(str2[i]==str2[p])
                        dp[i][j] = min(dp[i][j],(dp[i+1][p]+dp[p+1][j]));
                }
            }
        }
        for(int i=0;i<l;i++)
        {
            ans[i]=dp[0][i];
        }
        for(int i=0;i<l;i++)
        {
            if(str1[i]==str2[i])
            {
                ans[i]=ans[i-1];
            }
            else
            {
                for(int j=0;j<i;j++)
                {
                    ans[i]=min(ans[i],ans[j]+dp[j+1][i]);
                }
            }
        }
        printf("%d\n",ans[l-1]);
    }
    return 0;
}



發佈了51 篇原創文章 · 獲贊 8 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章