hdu 5050 Divided Land---2014acm上海賽區網絡賽

題目鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=5050


Divided Land

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 115    Accepted Submission(s): 57


Problem Description
It’s time to fight the local despots and redistribute the land. There is a rectangular piece of land granted from the government, whose length and width are both in binary form. As the mayor, you must segment the land into multiple squares of equal size for the villagers. What are required is there must be no any waste and each single segmented square land has as large area as possible. The width of the segmented square land is also binary.
 

Input
The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve.

Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 21000)
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then one number means the largest width of land that can be divided from input data. And it will be show in binary. Do not have any useless number or space.
 

Sample Input
3 10 100 100 110 10010 1100
 

Sample Output
Case #1: 10 Case #2: 10 Case #3: 110
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5052 5051 5049 5048 5046 
 

Statistic | Submit | Discuss | Note






用java大數類取個gcd就完了。。。一開始手寫了下gcd居然還共享了一次wa.......ORZ

import java.util.*;
import  java.math.*;

public class Main {
  public static void main(String [] args)throws Exception{
    Scanner cin=new Scanner(System.in);
        BigInteger one=new BigInteger("1");
        BigInteger zero=new BigInteger("0");
        BigInteger two= new BigInteger("2");
        BigInteger four= new BigInteger("4");
        BigInteger six = new BigInteger("6");
        BigInteger A;
        BigInteger B;
      int T;
      T=cin.nextInt();
      for(int tt=1;tt<=T;tt++){
        String a,b;
        a=cin.next();b=cin.next();
        A=new BigInteger(a,2);
        B=new BigInteger(b,2);
        BigInteger ans=A.gcd(B);
        System.out.print("Case #"+tt+": ");
        System.out.println(ans.toString(2));
      }
  }
}







發佈了132 篇原創文章 · 獲贊 26 · 訪問量 14萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章