ZOJ 3829 Known Notation (2014牡丹江H題)

題目鏈接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5383


Known Notation

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2

Author: CHEN, Cong
Source: The 2014 ACM-ICPC Asia Mudanjiang Regional Contest
Submit    Status


最近忙着各種事情,好久沒寫博客了。。。

這道題是牡丹H題,當時一直糾結一道概率DP。。。這題並沒有深入的想,到比賽後才搞出來。。。

首先我們可以先對字符串進行補全,因爲數字數目必須是’*‘數目+1。之後呢,我們發現對於‘*’,我們

其實只要把它儘可能的丟到後面去就完了。。然後從頭到尾掃一遍。

不過有些特殊情況記得要小心。。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string>
#include<map>
#include<set>
#include<vector>
#include<bitset>
#include<cstdlib>
#define CLR(A) memset(A,0,sizeof(A))
using namespace std;
int main(){
    int T;
    while(~scanf("%d",&T)){
        while(T--){
            string str;
            cin>>str;
            int cnum=0,cop=0,ans=0;
            for(int i=0;str[i];i++){
                if(str[i]>='0'&&str[i]<='9') cnum++;
                else cop++;
            }
            if(cnum<cop+1) {
                ans+=(cop+1-cnum);
                cnum=cop+1-cnum;
            }
            else cnum=0;

            if(cop==0){
                cout<<"0"<<endl;
                continue;
            }
            int len=str.size();
            int last=len-1;
            bool flag=0;
            while(last>=0&&!(str[last]>='0'&&str[last]<='9')) last--;
            for(int i=0;str[i];i++){
                if(i>=last) break;
                if(str[i]>='0'&&str[i]<='9'){ cnum++;}
                else{
                    if(cnum<2){
                        ans++;
                        cnum++;
                        last--;
                        flag=1;
                        while(last>=0&&!(str[last]>='0'&&str[last]<='9')) last--;
                    }
                    else cnum--;
                }
            }
            if(flag==0&&str[len-1]!='*') ans++;
            cout<<ans<<endl;
        }
    }
    return 0;
}






發佈了132 篇原創文章 · 獲贊 26 · 訪問量 14萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章