hdu 5053 the Sum of Cube---2014acm上海賽區網絡賽

題目鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=5053


the Sum of Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 140    Accepted Submission(s): 80


Problem Description
A range is given, the begin and the end are both integers. You should sum the cube of all the integers in the range.
 

Input
The first line of the input is T(1 <= T <= 1000), which stands for the number of test cases you need to solve.
Each case of input is a pair of integer A,B(0 < A <= B <= 10000),representing the range[A,B].
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then output the answer – sum the cube of all the integers in the range.
 

Sample Input
2 1 3 2 5
 

Sample Output
Case #1: 36 Case #2: 224
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5052 5051 5049 5048 5046 
 

Statistic | Submit | Discuss | Note


一道送分題,不過要小心中間過程溢出。。。


//#pragma comment(linker, "/STACK:36777216")
#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <sstream>
#include <iomanip>
#include <numeric>
#include <cstring>
#include <climits>
#include <cassert>
#include <complex>
#include <cstdio>
#include <string>
#include <vector>
#include <bitset>
#include <queue>
#include <stack>
#include <cmath>
#include <ctime>
#include <list>
#include <set>
#include <map>
using namespace std;
int main(){
    #ifdef ONLINE_JUDGE
    #else
        freopen("in.txt","r",stdin);
    #endif
    int T,kase=0;
    scanf("%d",&T);
    while(T--){
        printf("Case #%d: ",++kase);
        long long A,B;
        scanf("%I64d%I64d",&A,&B);
        long long sum=0;
        long long sum1=(A-1)*(A)/2;
        sum1=sum1*sum1;
        long long sum2=(B)*(B+1)/2;
        sum2=sum2*sum2;
        cout<<sum2-sum1<<endl;
    }
    return 0;
}





發佈了132 篇原創文章 · 獲贊 26 · 訪問量 14萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章