hdu-2680-Choose the best route

Link:

(http://acm.hdu.edu.cn/showproblem.php?pid=2680)

Choose the best route

   Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description

  One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input

  There are several test cases. 
  Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
  Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
  Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

  The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output

 1
-1

Source

2009浙江大學計算機研考複試(機試部分)——全真模擬

解釋

  這個題目比較精彩的部分就是對於多個出發點的設置,如果從出發點去找,那麼會找好長時間,所以我們自然考慮到倒過來尋找,照這個圖的反圖
  來尋找起點,然後查詢這些起點是否可以選擇。

Code

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn(1000);
const int INF(0x3f3f3f3f);
int dis[maxn];
int vis[maxn];
int map[maxn][maxn];
int n, m, s;
int least;
void input()
{
    for (int i = 1; i <= n; i++)
    {
        for (int j = 1; j < i; j++)
        {
            map[i][j] = map[j][i] = INF;
        }
        map[i][i] = 0;
    }
    int p, q, t;
    for (int i = 0; i < m; i++)
    {
        scanf("%d%d%d", &p, &q, &t);
        map[q][p] = min(map[q][p], t);
    }
}
void dijkstra(int src)
{
    for (int i = 1; i <= n; i++)
    {
        dis[i] = map[src][i];
        vis[i] = 0;
    }
    vis[src] = 1;
    int _min,min_loc;
    for (int i = 1; i < n; i++)
    {
        _min = INF;
        for (int j = 1; j <= n; j++)
        {
            if (!vis[j] && _min>dis[j])
            {
                _min = dis[j];
                min_loc = j;
            }
        }
        if (_min == INF)
            break;
        vis[min_loc] = 1;
        for (int j = 1; j <= n; j++)
        {
            dis[j] = min(dis[j], dis[min_loc] + map[min_loc][j]);
        }
    }
}
int main()
{
    while (scanf("%d%d%d",&n,&m,&s)==3)
    {
        input();
        int w;
        scanf("%d", &w);
        dijkstra(s);
        int from;
        least = INF;
        while (w--)
        {
            scanf("%d", &from);
            least=min(least,dis[from]);
        }
        if (least == INF)
            puts("-1");
        else
            cout << least << endl;
    }
    return 0;
}
發佈了37 篇原創文章 · 獲贊 6 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章