hdu-1003-Max Sum-動態規劃dp

Link:http://acm.hdu.edu.cn/showproblem.php?pid=1003

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

Author

Ignatius.L

Recommend

We have carefully selected several similar problems for you:  1176 1087 1069 2084 1058 

Code

#include <iostream>
#include <cstdio>
using namespace std;
const int maxn(1e5+10);
int arr[maxn];
int n;
int main()
{
    int t;
    scanf("%d",&t);
    int cnt=0;
    while(++cnt<=t)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",arr+i);
        }
        int first=1,last=1,maxsum=-9999999,sum=0,tmp=1;
        for(int i=1;i<=n;i++)
        {
            sum+=arr[i];
            if(sum>maxsum)
            {
                maxsum=sum;
                first=tmp;
                last=i;
            }
            if(sum<0)
            {
                sum=0;
                tmp=i+1;
            }
        }
        cout<<"Case "<<cnt<<":"<<endl;
        cout<<maxsum<<" "<<first<<" "<<last<<endl;
        if(cnt!=t)
            cout<<endl;
    }
    return 0;
}
發佈了37 篇原創文章 · 獲贊 6 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章