POJ 3069

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

  1. 題意:英語傷不起=-=, 大概就是 給出一個n 一個 r n是一條直線上面有n個點 的座標(相當於數軸) 在這些點上面放一個燈 給出的r 就是燈的照射範圍,讓你求出 最少給出多少個燈才能把一條線照滿
  2. 思路: 按照貪心的思路,充分的利用r到每個點的區間

import java.util.Arrays;
import java.util.Scanner;


public class Main {
    private static int n ,r,current=0;
    private static int[] array;
    public static void main(String[] args) {
    Scanner scanner = new Scanner(System.in);
    while (scanner.hasNext()) {
        current =0;
        r = scanner.nextInt();
        n = scanner.nextInt();
        if (n==-1&&r==-1) 
        break;
        array = new int[n];
        for (int i = 0; i < array.length; i++) {
        array[i] = scanner.nextInt();
        }
        int i=0;
        Arrays.sort(array);//先對這n個點排序
        while (i<n) {
        int x = array[i++];
        while (i<n&&x+r>=array[i]) //相當於第一個點加上r(照射範圍)大於下一個點,這樣下一個點就不用放燈了,直接i++,知道不能照到爲止
            i++;
        int  p = array[i-1];
        while (i<n&&p+r>=array[i]) //這就是下一個點了  同理以上
            i++;
        current ++;
        }
        System.out.println(current);

    }
    scanner.close();
    }

}
發佈了41 篇原創文章 · 獲贊 119 · 訪問量 17萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章