HDU 1250

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11897    Accepted Submission(s): 3972


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
100
 

Sample Output
4203968145672990846840663646 Note:
這個題的方法很多 這是我從別人博客上借鑑的,感覺挺簡潔的!
#include<stdio.h>
#include<string.h>
#define N 10000
#define M 300
int f[N][M];
void work()
{
    memset(f,0,sizeof(f));
    f[1][1]=f[2][1]=f[3][1]=f[4][1]=1;
    int i,j,t;
    for(i=5; i<N; i++)
    {
        t=0;
        for(j=1; j<M; j++)
        {
            t=t+f[i-1][j]+f[i-2][j]+f[i-3][j]+f[i-4][j];
            f[i][j]=t%100000000;
            t=t/100000000;
        }
    }
}

int main()
{
    int i,n;
    work();
    
    while(scanf("%d",&n)!=EOF)
    {
        i=M-1;
        while(f[n][i]==0) i--;
        printf("%d",f[n][i--]);
        while(i>=1)
        {
             printf("%08d",f[n][i]);
             i--;
        }
        printf("\n");
    }
    return 0;
}



發佈了41 篇原創文章 · 獲贊 9 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章