hdu2594 Simpsons’ Hidden Talents(exkmp模板)

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12391    Accepted Submission(s): 4296


 

Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

 

 

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

 

 

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

 

 

Sample Input


 

clinton homer riemann marjorie

 

 

Sample Output


 

0 rie 3

 

 

Source

HDU 2010-05 Programming Contest

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  2595 2596 2597 2598 2599 

 

 

 

題解:

爲了練exkmp,這題用了exkmp來打。

代碼(模板):

#include<bits/stdc++.h>
using namespace std;
int ans,nexr[200001],ex[200001];
void getnexr(char s[]){
	int i=0,j,po,len=strlen(s);
	nexr[0]=len;
	while(s[i]==s[i+1]&&i+1<len)i++;
	nexr[1]=i;
	po=1;
	for(i=2;i<len;i++){
		if(nexr[i-po]+i<nexr[po]+po)nexr[i]=nexr[i-po];
		 else{
		 	j=nexr[po]+po-i;
		 	if(j<0)j=0;
		 	while(i+j<len&&s[j]==s[i+j])j++;
		 	nexr[i]=j;
		 	po=i;
		 }
	}
}
void exkmp(char s1[],char s2[]){
	int i=0,j,po=0,len=strlen(s1),l2=strlen(s2);
	while(s1[i]==s2[i]&&i<l2&&i<len)i++;
	ex[0]=i;
	for(i=1;i<len;i++){
		if(nexr[i-po]+i<ex[po]+po)ex[i]=nexr[i-po];
		 else{
		 	j=ex[po]+po-i;
		 	if(j<0)j=0;
		 	while(i+1<len&&s1[j+i]==s2[j])j++;
		 	ex[i]=j;
		 	po=i;
		 }
	}
}
int main(){
	int i;
	char s1[200001],s2[200001];
	while(~scanf("%s%s",s1,s2)){
		getnexr(s1);
		exkmp(s2,s1);
		for(i=0;i<strlen(s2);i++)ans=max(ans,ex[i]);
		for(i=0;i<ans;i++)printf("%c",s1[i]);
		if(ans)printf(" %d\n",ans);
		 else printf("%d\n",ans);
		ans=0; 
	}
}

 

發佈了205 篇原創文章 · 獲贊 3 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章