hdu4288 coder

Coder

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6713    Accepted Submission(s): 2494


 

Problem Description

  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done. 1
  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete).
Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum.
  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations:
  1. add x – add the element x to the set;
  2. del x – remove the element x from the set;
  3. sum – find the digest sum of the set. The digest sum should be understood by


  where the set S is written as {a1, a2, ... , ak} satisfying a1 < a2 < a3 < ... < ak
  Can you complete this task (and be then fired)?
------------------------------------------------------------------------------
1 See http://uncyclopedia.wikia.com/wiki/Algorithm

 

 

Input

  There’re several test cases.
  In each test case, the first line contains one integer N ( 1 <= N <= 105 ), the number of operations to process.
  Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”.
  You may assume that 1 <= x <= 109.
  Please see the sample for detailed format.
  For any “add x” it is guaranteed that x is not currently in the set just before this operation.
  For any “del x” it is guaranteed that x must currently be in the set just before this operation.
  Please process until EOF (End Of File).

 

 

Output

  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty.

 

 

Sample Input


 

9 add 1 add 2 add 3 add 4 add 5 sum add 6 del 3 sum 6 add 1 add 3 add 5 add 7 add 9 sum

 

 

Sample Output


 
3 4 5

Hint

C++ maybe run faster than G++ in this problem.

 

 

Source

2012 ACM/ICPC Asia Regional Chengdu Online

 

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  4297 4289 4290 4291 4292 

 

 

 

題解:

原來線段樹還能這麼合併。。真是漲姿勢了

orz

題目大意:

 

有一個集合,每次操作都可以添加x,刪除x,或者查詢sum ,這個sum指的是在集合當中從小到大排序後,下標能夠對5取模後等於3的數。如上公式。

題解:

因爲x數很大,所以要離散化,離散化,那就是離線算法了。用線段樹來維護每次操作後整段區間的符合條件的的值。在每個節點上有兩個變量,一個num用來存儲以該節點爲根的樹上有多少值,一個sum[5],用來存儲在當前樹上位置取模後爲0、1、2、3、4的數的和。那麼怎麼將兩顆左右子樹合併到它的父節點上呢?先看一個數列:

(1 2 3 4 5 6 7   8 9 10 11 12)

(1 2 3 4 5 6 7 | 1 2 3 4 5 )假設這是由 ‘ | ’分隔開的左右子樹,上面的數列是合併後的數列。在左子樹上取模後爲3的是3,他在合併後的數列上仍然是3。但是看右子樹,取模後爲3的也是3,但是當他合併後變成了10,而10取模後是0.也就說在子樹合併的時候對於右子樹sum[i]可以直接相加,而右子樹的需要轉化一下。這個可以推導一下,轉化後爲sum[(i-num[左子樹]%5+5)%5],這樣的話就可以合併了。最後直接求根節點的sun[3]也就是整個區間上對5取模後餘3的和。

 

 

代碼:

#include <cstdio>
#include <cstring>
#include <map>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
struct node
{
    int id,x;
    char op[10];
}e[110005];
map<int,int>mp;
int val[110005];
long long sum[440005][5];
int  num[4400005];
bool cmp1(node a,node b)
{
    if(a.x==b.x)return a.op[0]<b.op[0];
    return a.x<b.x;
}
bool cmp2(node a,node b)
{
    return a.id<b.id;
}
void build(int root,int l,int r)
{
    num[root]=0;
    for(int i=0;i<5;i++)sum[root][i]=0;
    if(l==r)return ;
    int mid=(l+r)>>1;
    build(root<<1,l,mid);
    build(root<<1|1,mid+1,r);
}
void change(int root,int l,int r,int pos,int kis)
{
    if(l==r)
    {
        if(kis>0){
        num[root]=1;
        sum[root][1]=val[l];
        }
        else
        {
            num[root]=0;
            sum[root][1]=0;
        }
        return ;
    }
    int mid=(l+r)>>1;
    if(pos<=mid)
        change(root<<1,l,mid,pos,kis);
    else change(root<<1|1,mid+1,r,pos,kis);
    num[root]=num[root<<1]+num[root<<1|1];
    for(int i=0;i<5;i++)
    {
        sum[root][i]=sum[root<<1][i]+sum[root<<1|1][(i-num[root<<1]%5+5)%5];
    }
}
int main()
{
    int n,cnt;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%s",e[i].op);
            if(e[i].op[0]=='s')e[i].x=0;
            else scanf("%d",&e[i].x);
            e[i].id=i;
        }
        cnt=0;
        mp.clear();
        sort(e,e+n,cmp1);
        for(int i=0;i<n;i++)
        {
            if(!mp[e[i].x])
            {
                mp[e[i].x]=++cnt;
            }
            val[mp[e[i].x]]=e[i].x;
        }
        sort(e,e+n,cmp2);
        if(!cnt)
        {
            if(e[0].op[0]=='s')
                puts("0");
            continue;
        }
        //cout<<cnt<<endl;
        build(1,1,cnt);
        for(int i=0;i<n;i++)
        {
            if(e[i].op[0]=='a')
            {
                //cout<<mp[e[i].x]<<" "<<val[mp[e[i].x]]<<endl;
                change(1,1,cnt,mp[e[i].x],1);
            }
            else if(e[i].op[0]=='d')
            {
                change(1,1,cnt,mp[e[i].x],-1);
            }
            else
            {
                printf("%lld\n",sum[1][3]);
            }
        }
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章