HDOJ 2147 kiki's game 博弈

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/1000 K (Java/Others)
Total Submission(s): 5884    Accepted Submission(s): 3493


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
5 3 5 4 6 6 0 0
 

Sample Output
What a pity! Wonderful! Wonderful!
 

Author
月野兔
 

Source
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:  1850 1846 1847 1848 1849 
 

博弈入門題 ^_^ 首先畫個二維數組,標記上PN,然後發現P點是有規律的。

#include <iostream>
using namespace std;
int main()
{
	int n,m;
	while (cin>>n>>m && n && m){
		if (m%2 && n%2)
			cout<<"What a pity!"<<endl;
		else
			cout<<"Wonderful!"<<endl; 
	}
	return 0;
} 


kdwycz的網站:  http://kdwycz.com/

kdwyz的刷題空間:http://blog.csdn.net/kdwycz



發佈了105 篇原創文章 · 獲贊 3 · 訪問量 6萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章