POJ 2661 Factstone Benchmark 數學題

Factstone Benchmark
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3446   Accepted: 1779

Description

Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.) 
Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word. 
Given a year 1960 <= y <= 2160, what will be the Factstone rating of Amtel's most recently released chip?

Input

There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the Factstone rating.

Sample Input

1960
1981
0

Sample Output

3
8

Source


題意:求滿足 m! <= 2^n 的最大m,n已知。
兩邊取log:log1 + log2 +.....+logm <= n

話說大部分數學題程序都是很短的……

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
	int y;
	double i=1,n=0;
	while (cin>>y && y){
		y=4<<(y-1960)/10;
		while (n<y)
			n+=log(++i)/log(2); 
		cout<<(int)i-1<<endl;			
	}
	return 0;
}

kdwycz的網站:  http://kdwycz.com/

kdwyz的刷題空間:http://blog.csdn.net/kdwycz


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章