HDOJ 3032 Nim or not Nim Lasker's Nim遊戲

Nim or not Nim?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 858    Accepted Submission(s): 412


Problem Description
Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
 

Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)
 

Output
For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.
 

Sample Input
2 3 2 2 3 2 3 3
 

Sample Output
Alice Bob
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:  3031 3033 3038 3035 3034 
 

表示又到了學姿勢的時間了


Lasker's Nim遊戲:每一輪允許兩會中操作之一:①、從一堆石子中取走任意多個,②、將一堆數量不少於2的石子分成都不爲空的兩堆。

很明顯:sg(0) = 0,sg(1) = 1。
    狀態2的後繼有:0,1和(1,1),他們的SG值分別爲0,1,0,所以sg(2) =2。
    狀態3的後繼有:0、1、2、(1,2),他們的SG值分別爲0、1、2、3,所以sg(3) = 4。

    狀態4的後繼有:0、1、2、3、(1,3)和(2,2),他們的SG值分別爲0,1,2,4,5,0,所以sg(4) = 3.

由數學歸納法可以得出

sg(4k)=4k-1;sg(4k+1)=4k+1;sg(4k+2)=4k+2;sg(4k+3)=4k+4;

HDU 3032 Nim or not Nim?


#include <iostream>
using namespace std;
int main()
{
	int m,n,k,ans;
	cin>>m;
	while (m--){
		cin>>n;
		ans=0;
		while (n--){
			cin>>k;
			if (k%4==1 || k%4==2)
				ans^=k;
			else if (k%4==0)
				ans^=(k-1);
			else
				ans^=(k+1);
		}
		if (ans) cout<<"Alice\n";
		else cout<<"Bob\n";
	}
} 

kdwycz的網站:  http://kdwycz.com/

kdwyz的刷題空間:http://blog.csdn.net/kdwycz


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章