USACO Section 1.3.6 Prime Cryptarithm

題目

Prime Cryptarithm

The following cryptarithm is a multiplication problem that can be solved by substituting digits from a specified set of N digits into the positions marked with *. If the set of prime digits {2,3,5,7} is selected, the cryptarithm is called a PRIME CRYPTARITHM.

      * * *
   x    * *
    -------
      * * *         <-- partial product 1
    * * *           <-- partial product 2
    -------
    * * * *
Digits can appear only in places marked by `*'. Of course, leading zeroes are not allowed.

Note that the 'partial products' are as taught in USA schools. The first partial product is the product of the final digit of the second number and the top number. The second partial product is the product of the first digit of the second number and the top number.

Write a program that will find all solutions to the cryptarithm above for any subset of digits from the set {1,2,3,4,5,6,7,8,9}.

PROGRAM NAME: crypt1

INPUT FORMAT

Line 1: N, the number of digits that will be used
Line 2: N space separated digits with which to solve the cryptarithm

SAMPLE INPUT (file crypt1.in)

5
2 3 4 6 8

OUTPUT FORMAT

A single line with the total number of unique solutions. Here is the single solution for the sample input:

      2 2 2
    x   2 2
     ------
      4 4 4
    4 4 4
  ---------
    4 8 8 4

SAMPLE OUTPUT (file crypt1.out)

1


思路

簡單的枚舉,關鍵在於枚舉側略,我是把第一行看成一個數,第二行看成一個數,枚舉這兩個數字900*90的複雜度。後面分別判斷就行。

代碼

/*
ID:zhrln1
PROG:crypt1
LANG:C++
*/
#include <cstdio>
int n,b[11],k,ans;
int hash(int v){
    while (v){
        if (!b[v%10]) return 0;
        v/=10;
    }
    return 1;
}
int main(){
	freopen("crypt1.in","r",stdin);
	freopen("crypt1.out","w",stdout);
	scanf("%d",&n);
	for (int i(1);i<=n;i++){
		scanf("%d",&k);
		b[k]=1;
	}
	for (int i(111);i<1000;i++){
		if (hash(i)){
			for (int j(11);j<100;j++){

				if (i*j<10000 && i*(j/10)<1000 && i*(j%10)<1000 && hash(j) && hash(i*(j%10)) && hash(i*(j/10)) && hash(i*j)) {
                        ans++;
                       // printf("%d * %d = %d0 + %d = %d \n",i,j,i*(j/10),i*(j%10),i*j);
				}
			}
		}
	}
	printf("%d\n",ans);
	return 0;
}



發佈了59 篇原創文章 · 獲贊 14 · 訪問量 20萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章