HDU 1358 Period

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5098    Accepted Submission(s): 2467


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
3 aaa 12 aabaabaabaab 0
 

Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 

這個因爲不是匹配字符串,所以不需要當x[i] == x[i + 1]時令兩者next的值相等。而這個題又是求重複的循環子串的個數的問題,根據之前做的求循環子串補齊大小的題目類似。我們只需要確認只要當前位置與當前位置的next數組的值的差是當前位置的一個因子即可,且必須要求這個因子不能是當前位置本身。這個很好證明,當前位置與當前位置的next數組的值的差是循環子串的長度,只要這個長度是一個因子,當然是滿足是循環的。

代碼如下:

/*************************************************************************
	> File Name: Period.cpp
	> Author: Zhanghaoran
	> Mail: [email protected]
	> Created Time: Tue 24 Nov 2015 09:01:57 PM CST
 ************************************************************************/

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>

using namespace std;

void preKMP(char x[], int m, int nextKMP[]){
    int i , j;
    j = nextKMP[0] = -1;
    i = 0;
    while(i <= m){
        if(j == -1 || x[i] == x[j]){
            nextKMP[++ i] = ++ j;
            if(i % (i - j) == 0 && i / (i - j) > 1){
                cout << i << " " << i / (i - j) << endl;
            }
        }
        else 
            j = nextKMP[j];

    }
    cout << endl;
}
int nexti[1000010];
void KMP_Count(char x[], int m){
    int i, j;
    int ans = 0;
    preKMP(x, m, nexti);
}
int N;
char a[1000010];
int main(void){
    int cas = 1;
    while(1){
        scanf("%d", &N);
        if(N == 0)
            break;
        printf("Test case #%d\n",cas ++);
        scanf("%s", a);   
        KMP_Count(a, N);
    }
}


發佈了136 篇原創文章 · 獲贊 15 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章