HUST 1010 The Minimum Length

1010 - The Minimum Length

Time Limit: 1s Memory Limit: 128MB

Submissions: 1382 Solved: 519
Description
There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A.For example, A="abcdefg". I got abcdefgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.
Input
Multiply Test Cases.For each line there is a string B which contains only lowercase and uppercase charactors.The length of B is no more than 1,000,000.
Output
For each line, output an integer, as described above.
Sample Input
bcabcab
efgabcdefgabcde
Sample Output
3
7


這個題目是給定一個由一段字符串A重複組成的字符串B的一部分,且至少包含一個字符串A,求出那個串A的長度

這個題目再次彰顯KMP的強大。。。

因爲是至少包含一個完整的A,所以開頭第一個字母與後面組成的一個串長爲要求的串A的長度的序列一定與A是同構的,那麼由KMP算法求得的第m+1位的那個字符的next值與給出的字符串總長的差一定是這個要求的串A的長度。


代碼如下:

/*************************************************************************
	> File Name: The_Minimum_Length.cpp
	> Author: Zhanghaoran
	> Mail: [email protected]
	> Created Time: Wed 25 Nov 2015 12:17:00 AM CST
 ************************************************************************/

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>

using namespace std;
int Max = 0;
void preKmp(char x[], int m, int kmp_Next[]){
    int i, j;
    j = -1;
    kmp_Next[0] = -1;
    i = 0;
    while(i < m){
        if(j == -1 || x[i] == x[j]){
            kmp_Next[++i] = ++ j;
        }
        else
            j = kmp_Next[j];
        if(Max < j)
            Max = j;
    }
    kmp_Next[0] = 0;
}
int nexti[1000010];
char a[1000010];
int main(void){
    while(~scanf("%s", a)){
        preKmp(a, strlen(a), nexti);
        cout << strlen(a) - nexti[strlen(a)] << endl;
        Max = 0;
    }
}


發佈了136 篇原創文章 · 獲贊 15 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章