TOYS POJ2318 (計算幾何+叉積的應用+二分)

TOYSPOJ - 2318

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input
The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output
The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
Hint
As the example illustrates, toys that fall on the boundary of the box are "in" the box.

分析:
運用叉乘判斷點在那邊,二分找區間:
板子編號0~n-1;區間編號:0~n

二分裏面的s,e代表區間號;如果e==s則返回s;初始二分條件是0,n,代表存在範圍是[0,n];

中間找到mid之後二分的兩個區間是[s,mid],[mid+1,e]

代碼:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
const double eps=1e-8;

int dcmp(double x){
	if(abs(x)<eps)return 0;
	if(x<0)return -1;
	if(x>0)return 1;
}

struct Vector{
	double x,y;
	Vector(){}
	Vector(double x,double y):x(x),y(y){}
};

typedef Vector point;

Vector operator + (Vector a,Vector b){return Vector(a.x+b.x,a.y+b.y);}
Vector operator - (Vector a,Vector b){return Vector(a.x-b.x,a.y-b.y);}
Vector operator * (Vector a,Vector b){return Vector(a.x*b.x,a.y*b.y);}
Vector operator / (Vector a,Vector b){return Vector(a.x/b.x,a.y/b.y);}

double dot(Vector a,Vector b){
	return a.x*b.x+a.y*b.y; 
}

double cross(Vector a,Vector b){
	return a.x*b.y-a.y*b.x;
}

struct box{
	double up,down;
	box(){}
	box(double up,double down):up(up),down(down){}
	bool operator < (const box& b)const{
		return up<b.up&&down<b.down;
	}
}bs[5010];

int num[5010];

double X1,X2,Y1,Y2;

int b_find(double x,double y,int s,int e){
	if(e<=s)return s;
	int mid=(s+e)/2;
	//cout<<"s:"<<s<<" e:"<<e<<" mid:"<<mid<<endl;
	point p(x,y),a(bs[mid].up,Y1),b(bs[mid].down,Y2);
	if(cross(a-p,b-p)<0)return b_find(x,y,s,mid);
	else return b_find(x,y,mid+1,e);
}

int main(){
	int n,m;
	scanf("%d",&n);
	while(n){
		scanf("%d%lf%lf%lf%lf",&m,&X1,&Y1,&X2,&Y2);
		memset(num,0,sizeof(num));
		for(int i=0;i<n;i++){
			scanf("%lf%lf",&bs[i].up,&bs[i].down);
		}
		sort(bs,bs+n);
		for(int i=0;i<m;i++){
			double px,py;
			scanf("%lf%lf",&px,&py);
			//cout<<"hello"<<endl;
			int Mark=b_find(px,py,0,n);
			//cout<<"hello"<<endl;
			num[Mark]++;
		}
		for(int i=0;i<=n;i++){
			printf("%d: %d\n",i,num[i]);
		}
		printf("\n");
		scanf("%d",&n);
	}
	return 0;
}

發佈了68 篇原創文章 · 獲贊 0 · 訪問量 5255
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章