Sum of Consecutive Prime Numbers(POJ 2739)尺取法+數學問題

來自《挑戰程序設計競賽》

1.題目原文

Sum of Consecutive Prime Numbers
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 23592   Accepted: 12887

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

Source

2.解題思路

將一個整數分成連續素數之和,一共有多少種方法?
很符合尺取法的情況。很明顯要先處理出不超過n的所有素數,採用埃式篩法。

3.AC代碼

#include<algorithm>
#include<cctype>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iomanip>
#include<iostream>
#include<map>
#include<queue>
#include<string>
#include<set>
#include<vector>
#include<cmath>
#include<bitset>
#include<stack>
#include<sstream>
#include<deque>
#include<utility>
using namespace std;
#define INF 0x7fffffff
#define maxn 10005

int prime[maxn];
bool is_prime[maxn];//is_prime[i]是true表示i是素數
//返回n以內素數的個數
int sieve(int n)
{
    int p=0;
    for(int i=0;i<=n;i++) is_prime[i]=true;
    is_prime[0]=is_prime[1]=false;
    for(int i=2;i<=n;i++){
        if(is_prime[i]){
            prime[p++]=i;
            for(int j=2*i;j<=n;j+=i) is_prime[j]=false;
        }
    }
    return p;
}

int n;
void solve()
{
    int p=sieve(n);
    int s=0,t=0,sum=0;
    int res=0;
    for(;;){
       while(t<p&&sum<n){
           sum+=prime[t++];
       }
       if(sum<n) break;
       else if(sum==n){
            res++;

       }
       sum-=prime[s++];
    }
    printf("%d\n",res);
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n){
        solve();
    }
    return 0;
}


發佈了119 篇原創文章 · 獲贊 16 · 訪問量 5萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章