POJ 1789 Truck History

我只能說,題目描述的好像蠻厲害的樣子~

其實還只是一個prim的模板題~Orz

題意:給你N個字符串,每個字符串都只有7位,每兩個字符串會有一個“距離”,所謂的距離就是從0號位---6號位,一一對應過去,有1個字符不一樣就+1.所以距離就是兩個字符串的距離就是【0,7】,這樣就可以把每兩個字符串的距離算出來,而且第一個字符串不是派生出來的,所以就可以從第一個走起,建一個最小生成樹。

 

                                                                                                                                               Truck History
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 14101   Accepted: 5366

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

 

 

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <stdlib.h>
const int M = 2005;
int n;
char name[M][10];
bool visit[M];
int mp[M][M];
int dis[M];

void prim( int st )
{
	for( int i=0 ; i<n ; i++ ){
		visit[i] = false;
		dis[i] = mp[st][i];	
	}	
	dis[st] = 0;
	visit[st] = true;
	int ans = 0;
	int tmp , k;
	for( int i=0 ; i<n ; i++ ){
		tmp = 99999999;
		for( int j=0 ; j<n ; j++ ){
			if( !visit[j] && tmp > dis[j] )
				tmp = dis[ k = j ];	
		}
		if( tmp == 99999999 )
			break;
		ans += tmp;
		visit[k] = true;
		for( int j=0 ; j<n ; j++ ){
			if( !visit[j] && dis[j] > mp[k][j] )
				dis[j] = mp[k][j];
		}
	}
	printf("The highest possible quality is 1/%d.\n",ans);
}

int main()
{
	while( scanf("%d",&n) == 1 && n ){
		for( int i=0 ; i<n ; i++ )
			scanf("%s",name[i]);
		for( int i=0 ; i<n ; i++ ){
			for( int j=i+1 ; j<n ; j++ ){
				mp[i][j] = 0;
				for( int k=0 ; k<7 ; k++ ){
					if( name[i][k] != name[j][k] )
						mp[i][j]++;	
				}
				mp[j][i] = mp[i][j];
			}	
		}
		prim( 0 );	
	}
	return 0;
}


 

發佈了104 篇原創文章 · 獲贊 8 · 訪問量 11萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章