HUT G - QS Network

話說我這道題覺得用一個簡單的Dijkstra寫是錯誤的,但還是抱着試一下的心態提交了代碼,結果卻A了,不甘心吶

因爲題意是要求從一個點散發出消息,直到所有的點都收到,如果用最小生成樹寫的話,那樣我覺得不一定就是最小的花費啊。

因爲如果此時並不是所有的點都收到消息,那麼收到的消息的點還要繼續散發消息,所以最小生成樹不一定是最小花費吧,求大神解答啊Orz~

 

 

                                                                                                    G - QS Network
                                                   Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370

 

#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
#define MAX 1005
#define inf 0x7f7f7f
int n,m;
int num[MAX];
int mp[MAX][MAX];
int dis[MAX];
bool visit[MAX];

void prim( int st )
{
     for( int i=1 ; i<=n ; i++ ){
          visit[i] = false;
          dis[i] = mp[st][i];
     }     
     visit[st] = true;
     dis[st] = 0;
     int tmp ,k;
     int ans = 0;
     for( int i=1 ; i<n ; i++ ){
          tmp  = inf;
          for( int j=1 ; j<=n ; j++ )
               if( !visit[j] && tmp > dis[j] )
                   tmp  = dis[ k = j ];
          ans += tmp;
          visit[k] = true;
          for( int j=1 ; j<=n ; j++ )
               if( !visit[j] && dis[j] > mp[k][j] )
                   dis[j] = mp[k][j];     
     }
     printf("%d\n",ans);
}

int main()
{
    scanf("%d",&m);
    while( m-- ){
           scanf("%d",&n); 
           for( int i=1 ; i<=n ; i++ )
                scanf("%d",&num[i]);
           for( int i=1 ; i<=n ; i++ )  
                for( int j=1 ; j<=n ; j++ ){
                     scanf("%d",&mp[i][j]);
                     mp[i][j] += num[i]+num[j];
                }
           prim( 1 );
    }
    return 0;
}


 

發佈了104 篇原創文章 · 獲贊 8 · 訪問量 11萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章