【連通圖|割點】POJ-1144 Network

Network
Time Limit: 1000MS Memory Limit: 10000K

Description
A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input
The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output
The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2

Hint
You need to determine the end of one line.In order to make it’s easy to determine,there are no extra blank before the end of each line.

Source
Central Europe 1996


題意: 給出一個無向圖,求出其中的關節點個數。
思路: 該題的輸入格式非常噁心。要先輸入一個n,以n是否爲0判斷程序是否結束。
接下來有若干行,每行開頭有一個u,後面有若干個數字表示它們與u相連。詳見代碼。
除此之外就是求割點的Tarjan算法模板了。
代碼如下:

/*
 * ID: j.sure.1
 * PROG:
 * LANG: C++
 */
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <climits>
#include <iostream>
#define PB push_back
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
const double eps = 1e-8;
/****************************************/
const int N = 100 + 5;
bool mat[N][N], iscut[N];
int deep, dfn[N], n;

void init()
{
    memset(mat, 0, sizeof(mat));
    memset(dfn, 0, sizeof(dfn));
    memset(iscut, 0, sizeof(iscut));
    deep = 0;
}

int dfs(int u, int fa)
{
    int lowu = dfn[u] = ++deep;
    int son = 0;
    for(int v = 0; v < n; v++) if(mat[u][v]) {
        if(!dfn[v]) {
            son++;
            int lowv = dfs(v, u);
            lowu = min(lowu, lowv);
            if(lowv >= dfn[u]) iscut[u] = true;
        }
        else if(dfn[v] < dfn[u] && v != fa) {
            lowu = min(lowu, dfn[v]);
        }
    }
    if(fa == -1 && son == 1) iscut[u] = false;
    return lowu;
}

int main()
{
#ifdef J_Sure
    freopen("000.in", "r", stdin);
    //freopen("999.out", "w", stdout);
#endif
    while(scanf("%d", &n), n) {
        int u, v;
        init();
        while(scanf("%d", &u), u) {
            u--;
            while(getchar() != '\n') {
                scanf("%d", &v);
                v--;
                mat[u][v] = mat[v][u] = true;
            }
        }
        dfs(0, -1);
        int ans = 0;
        for(int i = 0; i < n; i++) {
            if(iscut[i]) ans++;
        }
        printf("%d\n", ans);
    }
    return 0;
}
發佈了437 篇原創文章 · 獲贊 20 · 訪問量 46萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章