Poj - 3694 Network(橋+LCA)

題目連接
A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can’t be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input
The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output
For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input
3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0
Sample Output
Case 1:
1
0

Case 2:
2
0

題意: N臺計算機由M條路連接,他們可以相互到達,但有些路徑至關重要,若刪除這條路徑,就有一些計算機無法到達。現在管理員添加一些邊,問每次添加之後,還有多少條關鍵路徑。
思路: 通過模擬一遍,我們不難發現,添加一條邊的兩個端點,它們通往LCA的過程中,路過的橋都變成了強連通分量。所以,每添加一條邊,就減少通往LCA過程中橋的數量。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int MAXN = 2e5+100;
struct Edge
{
    int v,next;
}e[MAXN<<1];
int head[MAXN],cnt;
int dfn[MAXN],low[MAXN],dep[MAXN],index;
int father[MAXN],mark[MAXN];
int n,m,sum;

void init()
{
    for(int i=0;i<=n;i++){
        head[i] = -1;
        dep[i] = dfn[i] = low[i] = 0;
        mark[i] = false;
    }
    index = cnt = sum = 0;
}

void addedge(int u,int v)
{
    e[cnt].next = head[u];
    e[cnt].v = v;
    head[u] = cnt++;

    e[cnt].next = head[v];
    e[cnt].v = u;
    head[v] = cnt++;
}

void Tarjan(int u,int pre)
{
    low[u] = dfn[u] = ++index;
    father[u] = pre;
    int flag = 0;
    for(int i=head[u];~i;i=e[i].next){
        int v = e[i].v;
        if(v == pre && !flag){ flag = 1; continue; }
        if(!dfn[v]){
            dep[v] = dep[u] + 1;
            Tarjan(v,u);
            low[u] = min(low[u],low[v]);
            if(low[v] > dfn[u]){
                mark[v] = true;
                sum++;
            }
        }
        else
            low[u] = min(low[u],dfn[v]);
    }
}

void LCA(int u,int v)
{
    while(dep[u] < dep[v]){
        if(mark[v])
            sum--,  mark[v]=false;
        v = father[v];
    }
    while(dep[v] < dep[u]){
        if(mark[u])
            sum--,  mark[u]=false;
        u = father[u];
    }
    while(u != v){
        if(mark[u])
            sum--,  mark[u]=false;
        if(mark[v])
        sum--,  mark[v]=false;
        v = father[v];
        u = father[u];
    }
}

int main()
{
    int cas = 0;
    while(scanf("%d%d",&n,&m),n+m){
        init();
        cout<<"Case "<<++cas<<":"<<endl;
        for(int i=1;i<=m;i++){
            int x,y;
            scanf("%d%d",&x,&y);
            addedge(x,y);
        }
        Tarjan(1,0);
        int q;
        scanf("%d",&q);
        for(int i=1;i<=q;i++){
            int x,y;
            scanf("%d%d",&x,&y);
            LCA(x,y);
            printf("%d\n",sum);
        }
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章