UVA-796 Critical Links(割邊)

In a computer network a link L, which interconnects two servers, is considered critical if there are at
least two servers A and B such that all network interconnection paths between A and B pass through L.
Removing a critical link generates two disjoint sub–networks such that any two servers of a sub–network
are interconnected. For example, the network shown in figure 1 has three critical links that are marked
bold: 0 -1, 3 - 4 and 6 - 7.
Figure 1: Critical links
It is known that:

  1. the connection links are bi–directional;
  2. a server is not directly connected to itself;
  3. two servers are interconnected if they are directly connected or if they are interconnected with
    the same server;
  4. the network can have stand–alone sub–networks.
    Write a program that finds all critical links of a given computer network.
    Input
    The program reads sets of data from a text file. Each data set specifies the structure of a network and
    has the format:
    no of servers
    server0 (no of direct connections) connected server . . . connected server
    . . .
    serverno of servers (no of direct connections) connected server . . . connected server
    The first line contains a positive integer no of servers(possibly 0) which is the number of network
    servers. The next no of servers lines, one for each server in the network, are randomly ordered and
    show the way servers are connected. The line corresponding to serverk, 0 ≤ k ≤ no of servers − 1,
    specifies the number of direct connections of serverk and the servers which are directly connected to
    serverk. Servers are represented by integers from 0 to no of servers − 1. Input data are correct. The
    first data set from sample input below corresponds to the network in figure 1, while the second data
    set specifies an empty network.
    Output
    The result of the program is on standard output. For each data set the program prints the number of
    critical links and the critical links, one link per line, starting from the beginning of the line, as shown
    in the sample output below. The links are listed in ascending order according to their first element.
    The output for the data set is followed by an empty line.
    Sample Input
    8
    0 (1) 1
    1 (3) 2 0 3
    2 (2) 1 3
    3 (3) 1 2 4
    4 (1) 3
    7 (1) 6
    6 (1) 7
    5 (0)
    0
    Sample Output
    3 critical links
    0 - 1
    3 - 4
    6 - 7
    0 critical links

題意: 在計算機網絡中,網絡的連接是無相圖,若刪除某條路徑使得他們直接不能相互達到,則這條路徑爲關鍵路徑,問關鍵路徑的個數。
思路: 割邊模板

#include<bits/stdc++.h>
using namespace std;
#define P pair<int,int>
const int MAXN = 1e5+10;
struct EDGE
{
    int v,next;
}e[MAXN];
int n,m,cnt,tot;
int head[MAXN],low[MAXN],dfn[MAXN];
int father[MAXN];
bool is_cut[MAXN];

void init()
{
    for(int i=0;i<=n;i++){
        head[i] = low[i] = dfn[i] = -1;
        father[i] = 0;
        is_cut[i] = false;
    }
    cnt = tot = 0;
}

void addedge(int u,int v)
{
    e[cnt].next = head[u];
    e[cnt].v = v;
    head[u] = cnt++;
}

void Tarjan(int x,int pre)
{
    father[x] = pre;
    dfn[x] = low[x] = ++tot;
    for(int i = head[x];~i;i = e[i].next){
        int v = e[i].v;
        if(dfn[v] == -1){
            Tarjan(v,x);
            low[x] = min(low[x],low[v]);
        }
        else if(pre != v)
            low[x] = min(low[x],dfn[v]);
    }
}

bool cmp(P t,P v)
{
    if(t.first == v.first)  return t.second < v.second;
    return t.first < v.first;
}

int main()
{
    while(~scanf("%d",&n)){
        init();
        for(int i=1;i<=n;i++){
            int x,m;
            scanf("%d (%d)",&x,&m);
            while(m--){
                int y;
                scanf("%d",&y);
                addedge(x+1,y+1);
                addedge(y+1,x+1);
            }
        }
        for(int i=1;i<=n;i++)
            if(dfn[i]==-1) Tarjan(i,0); //不是所有節點都是相互連接的
        int sum = 0;
        vector<pair<int,int> >ve;
        for(int i=1;i<=n;i++){
            int temp = father[i];
            if(temp > 0 && low[i] > dfn[temp]){
                if(temp > i)    ve.push_back(make_pair(i,temp));    //小號節點在前
                else ve.push_back(make_pair(temp,i));
            }
        }
        sort(ve.begin(),ve.end(),cmp);  //需要給節點排序
        cout<<ve.size()<<" critical links"<<endl;
        for(int i=0;i<ve.size();i++)
            cout<<ve[i].first-1<<" - "<<ve[i].second-1<<endl;
        cout<<endl;
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章