http://poj.org/problem?id=2253

Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 26038   Accepted: 8461

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
用flody求i到j的每條路徑上的最大步長的最小值!我把三層循環的位置弄反了,。。。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
double dist[300][300];
struct node{
   double x, y;
}point[300];
int n;

double get_dist(node a, node b) {
    double dx = a.x-b.x;
    double dy = a.y-b.y;
return sqrt(dx*dx+dy*dy);
}

int main() {
    for (int i = 1; scanf("%d", &n), n; i ++) {
        for (int j = 1; j <= n; j ++) {
            scanf("%lf%lf", &point[j].x, &point[j].y);
        }
        for (int j = 1; j <= n; j ++) {
            for (int k = j; k <= n; k ++) {
                dist[j][k] = dist[k][j] = get_dist(point[j], point[k]);
            }
        }

        for (int j = 1; j <= n; j ++) {
            for (int k = 1; k <= n; k ++) {
                for (int t = 1; t <= n; t ++) {
                    if (dist[k][t] > max(dist[k][j], dist[j][t])) {
                        dist[k][t] = max(dist[k][j], dist[j][t]);
                    }
                }
            }
        }
        printf("Scenario #%d\n", i);
        printf("Frog Distance = %.3f\n\n", dist[1][2]);
    }
return 0;
}


發佈了164 篇原創文章 · 獲贊 18 · 訪問量 13萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章