POJ 2187 Beauty Contest(凸包)

Description

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates. 

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input

4
0 0
0 1
1 1
1 0

Sample Output

2

Hint

Farm 1 (0, 0) and farm 3 (1, 1) have the longest distance (square root of 2) 



題目大意:

        給定平面內一些點,求最大的兩點間直線距離的平方

解題思路:

        凸包裸題,純粹模板,感覺數據是隨機出的,所以跑一遍凸包,然後兩兩枚舉凸包上的點,求出最大距離平方即可,不會超時,不需要旋轉卡殼(PS:弱也不會旋轉卡殼。。。。


#include <iostream>
#include <fstream>
#include <cstdio>
#include <cmath>
#include <map>
#include <set>
#include <bitset>
#include <ctime>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>
#include <list>

#define STD_REOPEN() freopen("../in.in","r",stdin)
#define STREAM_REOPEN fstream cin("../in.in")
#define INF 0x3f3f3f3f
#define _INF 63
#define eps 1e-8
#define MAX_V 100010
#define MAX_P 50010
#define MAX_E 10010
#define MAX 32000
#define MOD_P 3221225473
#define MOD 9901

using namespace std;

struct Point
{
	int x,y;
	Point(){}
	Point(int a,int b):x(a),y(b){}
	Point operator - (const Point a)const	//求向量
	{
		return Point(x-a.x,y-a.y);
	}
	int operator ^ (const Point a)const	//叉乘
	{
		return (x*a.y)-(y*a.x);
	}
	int operator & (const Point a)const	//兩點間距離
	{
		return (x-a.x)*(x-a.x)+(y-a.y)*(y-a.y);
	}
	bool operator < (const Point a)const
	{
		if(y==a.y)
			return x<a.x;
		return y<a.y;
	}
}s[MAX_P];

int GrahamScan(int n)
{
	if(n==2)
		return s[0]&s[1];
	sort(s,s+n);
	Point res[MAX_P];
	int top=0;
	for(int i=0;i<n;i++)
	{
		while(top>=2&&(Point(res[top-1]-res[top-2])^Point(s[i]-res[top-2]))<0)
			top--;
		res[top++]=s[i];
	}
	int len=top+1;
	for(int i=n-2;i>=0;i--)
	{
		while(top>=len&&(Point(res[top-1]-res[top-2])^Point(s[i]-res[top-2]))<0)
			top--;
		res[top++]=s[i];
	}
	int ans=0;
	for(int i=0;i<top;i++)
		for(int j=i+1;j<top;j++)
			ans=max(ans,res[i]&res[j]);
	return ans;
}

int main()
{
	//STD_REOPEN();
	int n;
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;i++)
			scanf("%d %d",&s[i].x,&s[i].y);
		int ans=GrahamScan(n);
		printf("%d\n",ans);
	}

    return 0;
}



發佈了104 篇原創文章 · 獲贊 28 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章