zoj 3329 One Person Game(概率dp,期望)

One Person Game

Time Limit: 1 Second      Memory Limit: 32768 KB      Special Judge

There is a very simple and interesting one-person game. You have 3 dice, namely Die1, Die2 and Die3. Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1, K2, K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers n, K1, K2, K3, a, b, c (0 <= n <= 500, 1 < K1, K2, K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698
 
題意:有三個骰子,分別有k1,k2,k3個面。
每次擲骰子,如果三個面分別爲a,b,c則分數置0,否則加上三個骰子的分數之和。
當分數大於n時結束。求遊戲的期望步數。初始分數爲0

思路:
設dp[i]表示達到i分時到達目標狀態的期望,pk爲投擲k分的概率,p0爲回到0的概率
則dp[i]=∑(pk*dp[i+k])+dp[0]*p0+1;
都和dp[0]有關係,而且dp[0]就是我們所求,爲常數
設dp[i]=A[i]*dp[0]+B[i];
代入上述方程右邊得到:
dp[i]=∑(pk*A[i+k]*dp[0]+pk*B[i+k])+dp[0]*p0+1
     =(∑(pk*A[i+k])+p0)dp[0]+∑(pk*B[i+k])+1;
     明顯A[i]=(∑(pk*A[i+k])+p0)
     B[i]=∑(pk*B[i+k])+1
     先遞推求得A[0]和B[0].
     那麼  dp[0]=B[0]/(1-A[0]);
 
 
AC代碼:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <cmath>
#include <algorithm>
#define ll long long
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
using namespace std;

const int INF = 1e9;
const int maxn = 1000005;
const int mod = 20140717;


int n, k1, k2, k3, a, b, c;
double p[600], A[600], B[600];
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d%d%d%d%d%d", &n, &k1, &k2, &k3, &a, &b, &c);
        double p0 = 1.0 / k1 / k2 / k3;
        memset(p, 0, sizeof(p));
        for(int i = 1; i <= k1; i++)
        for(int j = 1; j <= k2; j++)
        for(int k = 1; k <= k3; k++)
        if(i != a || j != b || k != c)
        {
            p[i + j + k] += p0;
        }
        memset(A, 0, sizeof(A));
        memset(B, 0, sizeof(B));
        for(int i = n; i >= 0; i--)
        {
            A[i] = p0, B[i] = 1;
            for(int j = 1; j <= k1 + k2 + k3; j++)
            {
                A[i] += A[i + j] * p[j];
                B[i] += B[i + j] * p[j];
            }
        }
        printf("%.16f\n", B[0] / (1 - A[0]));
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章