L1-064 估值一亿的AI核心代码 (20分)

AI.jpg

以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

无论用户说什么,首先把对方说的话在一行中原样打印出来;
消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
把原文中所有大写英文字母变成小写,除了 I;
把原文中所有独立的 can youcould you 对应地换成 I canI could—— 这里“独立”是指被空格或标点符号分隔开的单词;
把原文中所有独立的 Ime 换成 you
把原文中所有的问号 ? 换成惊叹号 !;
在一行中输出替换后的句子作为 AI 的回答。

输入格式:

输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:

按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
 Good to chat   with you
can   you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:

Hello ?
AI: hello!
 Good to chat   with you
AI: good to chat with you
can   you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know

正则表达式

#include <iostream>
#include <string>
#include <regex>
using namespace std;

int main() {
	int N;
	string s;
	cin >> N;
	getchar();
	while (N--) {
		getline(cin, s);
		cout << s << endl << "AI: ";
		for (int i = 0; i < s.size(); ++i)
			if (s[i] != 'I')
				s[i] = tolower(s[i]);
		s = regex_replace(s, regex(R"(\s+)"), " ");
		if (s.front() == ' ') s.erase(s.begin());
		if (s.back() == ' ') s.pop_back();
		s = regex_replace(s, regex(R"( ?\?| !)"), "!");
		s = regex_replace(s, regex(R"( ,)"), ",");
		s = regex_replace(s, regex(R"( ')"), "'");
		s = regex_replace(s, regex(R"( \.)"), ".");
		s = regex_replace(s, regex(R"(\bI\b|\bme\b)"), "y_u");		//测试点1:考虑到can I的情况
		s = regex_replace(s, regex(R"(\bcan you\b)"), "I can");
		s = regex_replace(s, regex(R"(\bcould you\b)"), "I could");
		s = regex_replace(s, regex(R"(y_u)"), "you");
		cout << s << endl;
	}
}

上面那个是自己现学了正则表达式语法写出来的,下面的是学长写好的,也get到了一个新的输入输出类

#include <iostream>
#include <sstream>
using namespace std;

int main() {
	int N;
	string s;
	cin >> N;
	getchar();
	while (N--) {
		getline(cin, s);
		cout << s << endl << "AI:";
		for (int i = 0; i < s.size(); ++i) {
			if (isalnum(s[i])) {
				if (s[i] != 'I')
					s[i] = tolower(s[i]);
			}
			else {
				s.insert(i, " ");
				i++;
			}
			if (s[i] == '?')
				s[i] = '!';
		}
		stringstream str(s);
		string a[1000];
		int cnt = 0;
		while (str >> s) 
			a[cnt++] = s;
		if (!isalnum(a[0][0]))
			cout << " ";
		for (int i = 0; i < cnt; ++i) {
			if (!isalnum(a[i][0])) {
				cout << a[i];
			}
			else if (a[i] == "can" && a[i + 1] == "you") {
				cout << " I can";
				i++;
			}
			else if (a[i] == "could" && a[i + 1] == "you") {
				cout << " I could";
				i++;
			}
			else if (a[i] == "I" || a[i] == "me")
				cout << " you";
			else
				cout << " " << a[i];
		}
		cout << endl;
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章