HDU 4020 Ads Proposal

Ads Proposal

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 2127    Accepted Submission(s): 707


Problem Description
There are N customers set their M different advertisements on Baidu. Each advertisement is owned by single customer. The ads system of Baidu records the number of clicks of each advertisement this year. The proposal system wants to analysis the advertisements about the relativity of the description length and the number of clicks of the advertisements. During the analysis, it is very important to do such a query to ask the total length of the advertisements with top k clicking times for each customer. You may assume the number of clicks of all advertisements are distinct.
Your task is to help Baidu to design this little toolkit.
 

Input
The input consist multiple test cases. The number of test cases is given in the first line of the input.
  For each test case, the first line contains three integers N, M and Q, denoting the number customer, the number of advertisement instances and the number of queries. (N <= 100000, M <= 500000, Q <= 100000)
  Then M lines follow, each line contains three numbers, U, C and L, indicating the owner of this advertisement, the clicks for this advertisement and the length. (1 <= U <= N, 0 <= C, L <= 1000000000)
  Finally Q lines come. Each line contains only one integer k, representing the query for top k clicking advertisements for each customer.
 

Output
For each test case, output Q lines, each line contains only one integer, denoting the sum of total length of the top k number of clicks for each customer.
 

Sample Input
2 2 4 3 1 12 13 2 23 41 1 21 46 1 22 31 1 2 3 6 15 3 5 2677139 731358928 2 347112028 239095183 6 27407970 85994789 6 767687908 734935764 6 255454855 110193353 3 39860954 813158671 5 617524049 55413590 3 338773814 7907652 6 810348880 736644178 2 777664288 63811422 6 590330120 616490361 5 552407488 136492190 1 416295130 448298060 5 811513162 232437061 4 43273262 874901209 4 9 13
 

Sample Output
Case #1: 72 118 131 Case #2: 5801137622 5887132411 5887132411
 

Source
 

題意: 有N個客戶投資了M個廣告,現給出M個廣告的信息(所屬客戶 , 點擊量 , 廣告長度)
         現給Q次查詢,輸出每個客戶點擊量前K大的廣告長度之和

題解:sort一遍,先按客戶排序,再按點擊量排序,再處理出前k大的所有答案。

#include <cstring>
#include <cstdio>
#include <algorithm>
#include <iostream>
#include <vector>
#include <set>
#define Mod 1000007

using namespace std;
typedef long long ll;
const int N = 100010;
int n,m,q;

struct node {
    ll c,l;
    int id;
} a[N*5];

ll sk[N*5];

bool cmp(node a,node b) {
    return a.id<b.id||(a.id==b.id&&a.c>b.c);
}

int main() {
   // freopen("test.in","r",stdin);
    int t,ca=1;
    cin>>t;
    while(t--) {
        scanf("%d%d%d",&n,&m,&q);
        for(int i=0; i<m; i++) {
            scanf("%d%I64d%I64d",&a[i].id,&a[i].c,&a[i].l);
        }
        sort(a,a+m,cmp);
        memset(sk,0,(m+2)*sizeof(sk[0]));///初始化沒有限制會TLE
        int o=1;
        sk[o++]+=a[0].l;
        for(int i=1; i<m; i++) {
            if(a[i].id!=a[i-1].id) {
                o=1;
            }
            sk[o++]+=a[i].l;
        }
        for(int i=1; i<=m; i++)
            sk[i]+=sk[i-1];
        printf("Case #%d:\n",ca++);
        int k;
        while(q--) {
            scanf("%d",&k);
            if(k>m)k=m;
            printf("%I64d\n",sk[k]);
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章