POJ 3349 Snowflake Snow Snowflakes(hash)

Snowflake Snow Snowflakes
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 35451   Accepted: 9334

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

Source


題意:判斷是否存在兩片一樣的雪花。

題解:將每片雪花hash成一個值,正序和逆序都判斷一下。

#include <cstring>
#include <cstdio>
#include <algorithm>
#include <iostream>
#include <vector>
#define Mod 1000007

using namespace std;
const int N = 100010;

vector<int>tu[Mod+5];
int n;
int Six[N][6];

void init() {
    for(int i=0; i<=Mod+1; i++)
        tu[i].clear();
}

int Hash(int i) {
    int res=0;
    for(int j=0; j<6; j++)
        (res+=Six[i][j])%Mod;
    return res%Mod;
}

bool same(int a,int b) {
    for(int i=0; i<6; i++) {
        bool flag=true;
        ///正序判斷
        for(int j=0; j<6; j++) {
            if(Six[a][j]!=Six[b][(j+i)%6]) {
                flag=false;
                break;
            }
        }
        if(flag)return true;
        flag=true;
        ///逆序判斷
        for(int j=0; j<6; j++) {
            if(Six[a][j]!=Six[b][(i-j+6)%6]) {
                flag=false;
                break;
            }
        }
        if(flag)return true;
    }
    return false;
}

int main() {
    //freopen("test.in","r",stdin);
    //while(~scanf("%d",&n))
    scanf("%d",&n);
    {
        for(int i=0; i<n; i++) {
            for(int j=0; j<6; j++) {
                scanf("%d",&Six[i][j]);
            }
        }
        init();
        bool flag=false;
        for(int i=0; i<n; i++) {
            if(flag)break;
            int h=Hash(i);
            for(int j=0; j<tu[h].size(); j++) {
                if(same(i,tu[h][j])) {
                    flag=true;
                    break;
                }
            }
            tu[h].push_back(i);
        }
        if(flag)printf("Twin snowflakes found.\n");
        else    printf("No two snowflakes are alike.\n");
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章