hdu 3232 Crossing Rivers(求期望)

Crossing Rivers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 756    Accepted Submission(s): 397


Problem Description
You live in a village but work in another village. You decided to follow the straight path between your house (A) and the working place (B), but there are several rivers you need to cross. Assume B is to the right of A, and all the rivers lie between them.

Fortunately, there is one "automatic" boat moving smoothly in each river. When you arrive the left bank of a river, just wait for the boat, then go with it. You're so slim that carrying you does not change the speed of any boat.

Days and days after, you came up with the following question: assume each boat is independently placed at random at time 0, what is the expected time to reach B from A? Your walking speed is always 1.

To be more precise, for a river of length L, the distance of the boat (which could be regarded as a mathematical point) to the left bank at time 0 is uniformly chosenfrom interval [0, L], and the boat is equally like to be moving left or right, if it’s not precisely at the river bank.
 

Input
There will be at most 10 test cases. Each case begins with two integers n and D, where n (0 <= n <= 10) is the number of rivers between A and B, D (1 <= D <= 1000) is the distance from A to B. Each of the following n lines describes a river with 3 integers: p, L and v (0 <= p < D, 0 < L <= D, 1 <= v <= 100). p is the distance from A to the left bank of this river, L is the length of this river, v is the speed of the boat on this river. It is guaranteed that rivers lie between A and B, and they don’t overlap. The last test case is followed by n=D=0, which should not be processed.
 

Output
For each test case, print the case number and the expected time, rounded to 3 digits after the decimal point.

Print a blank line after the output of each test case.
 

Sample Input
1 1 0 1 2 0 1 0 0
 

Sample Output
Case 1: 1.000 Case 2: 1.000
 

Source
 

題意:A、B兩點之間距離爲D,並且在A、B之間有n條河,每條河上有一條自動船。船的寬度爲L,

          把船看成一個點時,已知步行的速度爲1,船的速度爲v,每條河與A點的距離爲P,求A到B花

          費的時間的期望是多少。

題解:假設船在剛好在河岸,河的寬度爲L,船的速度爲v,則有兩種情況,一種是人剛好能坐上船,等

          的時間爲0;一種是剛好坐不上,等的時間是2*L/v,船在任意位置都存在這兩種情況,所以等船

          時間的期望是T=(0+2*L/v)/2,所以過河時間的期望爲T+L/v=2*L/v;

#include<cstring>
#include<algorithm>
#include<cstdio>
#include<iostream>
using namespace std;

const int N=55;
int n, d;

int main() {
   // freopen("test.in","r",stdin);
    int ca=1;
    while(~scanf("%d%d",&n,&d)) {
        if(n==0&&d==0)break;
        double s=0;
        double ans=0;
        double dd=(double)d;
        for(int i=0; i<n; i++) {
            double p,l,v;
            scanf("%lf%lf%lf",&p,&l,&v);
            s+=l;
            ans+=2*l/v;
        }
        ans+=(dd-s);
        printf("Case %d: %.3f\n\n",ca++,ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章