PAT(甲級)2019年冬季考試 7-2 Block Reversing (25分)

7-2 Block Reversing (25分)

Given a singly linked list L. Let us consider every K nodes as a block (if there are less than K nodes at the end of the list, the rest of the nodes are still considered as a block). Your job is to reverse all the blocks in L. For example, given L as 1→2→3→4→5→6→7→8 and K as 3, your output must be 7→8→4→5→6→1→2→3.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
​5
​​ ) which is the total number of nodes, and a positive K (≤N) which is the size of a block. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 8 3
71120 7 88666
00000 4 99999
00100 1 12309
68237 6 71120
33218 3 00000
99999 5 68237
88666 8 -1
12309 2 33218

Sample Output:

71120 7 88666
88666 8 00000
00000 4 99999
99999 5 68237
68237 6 00100
00100 1 12309
12309 2 33218
33218 3 -1

思路:

先遍歷一遍並標記,然後從大到小排序,之後再按照題目分塊從小到大排序。
注意:最後的“尾巴”處理,可能不是整數
在這裏插入圖片描述

Code:

#include<cstdio> 
#include<iostream> 
#include<vector> 
#include<map>
#include<string>
#include<set>
#include<cctype>
#include<algorithm>
using namespace std;
const int INF = 0x3fffffff;
const int maxn = 100010;
struct node{
	int address,data,next,flag;
	node(){
		flag = -1;
	}
}Node[maxn];
bool cmp1(node a,node b){
	return a.flag > b.flag;
}
bool cmp2(node a,node b){
	return a.flag < b.flag;
}
int main(){
	int start,n,k;
	scanf("%d%d%d",&start,&n,&k);
	for(int i = 0; i < n; i++){
		int add;
		scanf("%d",&add);
		scanf("%d%d",&Node[add].data,&Node[add].next);
		Node[add].address = add;
	}
	int cnt = 0;
	for(int p = start; p != -1; p = Node[p].next){
		Node[p].flag = cnt++;
	}
	sort(Node,Node+maxn,cmp1);
	int temp = cnt % k;
	if(temp != 0){
		sort(Node,Node+temp,cmp2);
	}
	for(int i = temp; i + k <= cnt; i+=k){
		sort(Node+i,Node+i+k,cmp2);
	}
	for(int i = 0; i < cnt; i++){
		if(i != cnt - 1)
			printf("%05d %d %05d\n",Node[i].address,Node[i].data,Node[i+1].address);
		else printf("%05d %d -1\n",Node[i].address,Node[i].data);
	}
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章